TN console start up error

Vikas,

  1. First check if u have WmTN package installed properly.
  2. Check if u executed all the sql scripts provided (depends on which db u have).
  3. In the Functional Alias Definitions, under Associated Pool Alias, check if u have an entry of the Pool Alias. If not, associate JDBC Functional Alias to the Pool Alias (under JDBC Pools --> Functional Alias Definitions --> Edit Association).
  4. Re-load WmTN package.

Let us know if it works.

Thanks

If you try Nasir’s tips and nothing happens. Try to connect to your database to confirm your DB can be connected to from your machine. Use whatever client you use for SQL scripts.

Let us know hwat happens
Jim

Hello Nasir,

  1. Yes I do have the WmTN package installed
  2. I didnt execute any scripts. Actually the sql server that I am connecting to is already being used for trading networks by other developers who can succesfully start the TN console. So I am sure the scripts were run before the the database.
  3. Now here lies the problem. I dont have any functional aliases. Here is how my JDBC pools section looks like.

Please let me know if you have further inputs.

Thanks,
Vikas.

ok, check the folder “function” under
<is_server>\config\jdbc\function and see if you have any of xml file(s) in that folder.
Let me know.

Yes I do have the following xml files

ISCoreAudit.xml, ProcessAudit.xml, TN.xml, Xref.xml

Vikas.

Vikas,
If u have these files, there must be 4 Functional Alias Definitions. But now, I am not sure why you are not getting any function name in the JDBC Pools.
Can you see “Trading Networks” under Solutions in the IS Admin page?
If its not there, probably some installation problem with the TN package.

Try to restart your server and then check if problem continues or not.

Thanks

No, I dont see “Trading Networks” under solutions. But to make matters worse, even the other developer dosent have “Trading Networks” under solution. But he can still start the TN console .

Vikas.

Paste TN.xml file which I am sending to the same folder. First, make backup of your original file somewhere.

Then restart your server and see if problem continues. If it is, you may have to install TN again.

TN.xml
TN.xml (0.4 k)

The TN.xml file is exactly similar to the one I have. I have started a fresh installation. Hope it works after this. Will let you know.

Thanks for the help.
Vikas.

Good Luck!!!

can any one send me small example or steps to register the document to TN and send it …plz

looking forward
shanti

Seen this error before. Want to post answers just in case someone else wondering in future. It might be problem under any subdirectory of the config/jdbc, not just config/jdbc/function. For example, if you create a backup file and saved it under jdbc/pool with different extension, it will cause the same problem. IS reads everything under these directories regardless if the extension is .xml or not. The simple way to fix is to delete everything under jdbc/pool, and replace all files under jdbc/function and jdbc/driver from a healthy IS. If you are backing up files, don¡¯t save it under the same directory using different extension thinking that server will pass it. That will cause all jdbc function alias gone from IS admin and TN can¡¯t startup.


well now iam getting this error
how to rectify
The Server could not process your request because the following error occurred. Contact your server administrator.

Service wm.tnweb.configFlow:loadMenu
Error class com.wm.app.tn.err.EXMLException
TRNSERV.000012.000066 Could not get host profile. java.lang.NullPointerException java.lang.NullPointerException at wm.tn.profile.getHostProfile(profile.java:249) at java.lang.reflect.Method.invoke(Native Method) at com.wm.app.b2b.server.JavaService.baseInvoke(JavaService.java:287) at com.wm.app.b2b.server.invoke.InvokeManager.process(InvokeManager.java:554) at com.wm.app.b2b.server.invoke.StatisticsProcessor.process(StatisticsProcessor.java:44) at com.wm.app.b2b.server.invoke.ServiceCompletionImpl.process(ServiceCompletionImpl.java:221) at com.wm.app.b2b.server.invoke.ValidateProcessor.process(ValidateProcessor.java:49) at com.wm.app.b2b.server.ACLManager.process(ACLManager.java:194) at com.wm.app.b2b.server.invoke.DispatchProcessor.process(DispatchProcessor.java:39) at com.wm.app.b2b.server.AuditLogManager.process(AuditLogManager.java:384) at com.wm.app.b2b.server.invoke.InvokeManager.invoke(InvokeManager.java(Compiled Code)) at com.wm.app.b2b.server.invoke.InvokeManager.invoke(InvokeManager.java:359) at com.wm.app.b2b.server.ServiceManager.invoke(ServiceManager.java:246) at com.wm.app.b2b.server.BaseService.invoke(BaseService.java:155) at com.wm.lang.flow.FlowInvoke.invoke(FlowInvoke.java:324) at com.wm.lang.flow.FlowState.invokeNode(FlowState.java:580) at com.wm.lang.flow.FlowState.step(FlowState.java:438) at com.wm.lang.flow.FlowState.invoke(FlowState.java(Compiled Code)) at com.wm.app.b2b.server.FlowSvcImpl.baseInvoke(FlowSvcImpl.java:1749) at com.wm.app.b2b.server.invoke.InvokeManager.process(InvokeManager.java:554) at com.wm.app.b2b.server.invoke.StatisticsProcessor.process(StatisticsProcessor.java:44) at com.wm.app.b2b.server.invoke.ServiceCompletionImpl.process(ServiceCompletionImpl.java:221) at com.wm.app.b2b.server.invoke.ValidateProcessor.process(ValidateProcessor.java:49) at com.wm.app.b2b.server.ACLManager.process(ACLManager.java:194) at com.wm.app.b2b.server.invoke.DispatchProcessor.process(DispatchProcessor.java:39) at com.wm.app.b2b.server.AuditLogManager.process(AuditLogManager.java:384) at com.wm.app.b2b.server.invoke.InvokeManager.invoke(InvokeManager.java(Compiled Code)) at com.wm.app.b2b.server.invoke.InvokeManager.invoke(InvokeManager.java:359) at com.wm.app.b2b.server.ServiceManager.invoke(ServiceManager.java:246) at com.wm.app.b2b.server.ServiceManager.invoke(ServiceManager.java:128) at com.wm.app.b2b.server.ns.Namespace.invoke(Namespace.java:533) at com.wm.util.template.Reporter.invoke(Reporter.java:963) at com.wm.util.template.InvokeToken.eval(InvokeToken.java:75) at com.wm.util.template.TemplateToken.evalChild(TemplateToken.java(Compiled Code)) at com.wm.util.template.TemplateToken.eval(TemplateToken.java(Compiled Code)) at com.wm.util.template.Reporter.reportNoReset(Reporter.java:1299) at com.wm.util.template.Reporter.reportToOutput(Reporter.java:1274) at com.wm.util.template.Reporter.reportIData(Reporter.java:1163) at com.wm.app.b2b.server.HTTPDocHandler._process(HTTPDocHandler.java:490) at com.wm.app.b2b.server.HTTPDocHandler.process(HTTPDocHandler.java:112) at com.wm.app.b2b.server.Dispatch.run(Dispatch.java:311) at com.wm.util.pool.PooledThread.run(PooledThread.java:105) at java.lang.Thread.run(Thread.java:512&#

Regarding the Oracle error:

Open a sqlplus window and log in to oracle with the same userid and password you have configured in the JDBC pool screen.

Type: select count(*) from BizDoc;

If you don’t get a count back, then you have not created the tables in the default schema for the userid and password you are providing. As soon as select count(*) form BizDoc works in sqlplus without any schema qualification for the table name, the same user id and password should also work for the JDBC connection.

If you are still getting this error after you have verified the tables have been created in the default schema for the userid, then I would run the drop scripts, and re-create, this time carefully checking for errors (like out of tablespace, etc.) when creating the tables.

I would not start working on the second error until you have the database connection issue resolved.

Regards

Hi Vikas,
I just want to know how did u resolve the problem with the functional alias, even its not displaying for me in my IS … I have tried almost everything from running the tables scripts to re-installing the TN, but it has’nt solved the problem. If you can kindly tell me how u solved the problem i would really appreciate.

Leon

I have noticed that restarting IS from the webserver seems to be a problem when this issue crops up. My WM server got into this state when a users TN console on his windows box blew up during a profile save.

Restarting from the web interface didn’t help. However, shutting down the service from the shell and then starting IS (/opt/webMethods6/IntegrationServer/bin/server.sh) cleared up this problem.