TN 6 cannot connect to sql server database

I am experimenting with TN 4.6 and TN 6.0. TN 4.6 works ok with the built-in database (cloudscape), but I cannot get 6.0 to connect to the database.

Apparently there is no built-in database available for TN 6.0, so I chose to use sql server. I ran the db install scripts which successfully created about 30 tables for TN in a database called TN_TEST.

I then configured a JDBC Pool Alias for TN as follows:

Functional Alias Definitions
TN Trading Networks Function

Pool Alias Definitions
Alias Name: TN
Associated Driver Alias: DataDirect Connect JDBC SQL Server Driver
Database URL: jdbc:sqlserver://;databaseName=TN_TEST;SelectMethod=cursor
User Id: sa
Password: *****

When I try to connect to TN with WmTNWeb I get the following error:
“could not get host profile”

When I try to connect to TN with TNconsole I get the following error:
“there was a database error fetching the model version info from your database, connection refused”

I tried windows authentication as well as well as sql server authentication.

Check below:

Try using the type 4 JDBC driver from Microsoft.

Driver =

Database URL = jdbc:microsoft:sqlserver://;databaseName=XYZ

You will be required to have the following JARS in your classpath


To add a peny to this, IS 4.6 had this problem whether 6.0 has it or not,I don’t know.When you configure your MSSQL driver, first time the driver won’t come in the drop down list. So after you are done even if the drivers does not come up do a TEST and see if you get all the tables or not. After that the SQL server driver will be seen in the drop down list.

Hi Richard,
Is your SQL Server database in the same box as your WM server? Did you try to make a connection to the database from Settings -> Control Panel -> Administrative Tools -> Data Sources (System DSN)

Once you get that configured, it would be easier.
Good Luck.

I really appreciate your help on this. Here is where I am at.

Successful case #1 (retrieve from MS-Access DB via ODBC)

Ran execSQL service against MS-access database using these parameters
where laptop_sqlserver is a DSN for ODBC
DB Driver

Successful case #2 (retrieve from TN DB via ODBC)

Ran execSQL service against SQL server database using these parameters
DB URL;databaseName=TN_TEST;SelectMethod=cursor
where TN_TESTis a the TN database under sql server
DB Driver

Unsuccessful case (wm startup of TN with JDBC Pools)

Functional Alias Definition TN Pool Alias
TN TNpool

Pool Alias Definition Associated Driver
TNpool sqlserverdriver

Driver Alias Definition Class Name

The following driver jars are placed in <wbbase>\IntegrationServer\lib\jars

This case fails during startup of IS with the following errors:
starting wm for Trading Networks
loading system configuration
There was a database error fetching the model version info from your database

Where do I go from here? Try DataDirect Drivers???

Hi Guys ,
I am trying to do the similar thing using Merant drivers and SQL server 7.
But I get following error

"Test of TN Failed
[MERANT][SequeLink JDBC Driver]TCP/IP error, connection reset by peer. "

webMethods class Path

Server Classpath D:\webMethods61\IntegrationServer\lib\classes\

I have my merant server and client agent installed on server running SQL server 7

I am using following configuration in Pool alias configuration for Functional Alias Definitions “TN”

Alias Name:TN
Alias Description:TN
Associated Driver Alias:DataDirect SequeLink JDBC Driver (TN Only) which is (com.merant.sequelink.jdbc.SequeLinkDriver) in Driver Alias Definitions

Database URL:jdbc:sequelink://sqlserver7:1433;databaseName=WmTN
User Id:xxx
Password :xxx
Minimum Connections 1
Maximum Connections 5
Idle Timeout milliseconds 18000

I have tested ODBC connection and it is working fine.
Can anybody guide on what could be wrong here?


I believe (:wink: is missing at the last part of the URL,

Database URL:jdbc:sequelink://sqlserver7:1433;databaseName=WmTN;

Pls check with this change.


hi everyone,

I’ve installed WM 6 on my machine, but I’m suffering some problems. At first, when starting up the Integration Server, I’m getting the following execption after the server said"Starting webMethods for Trading Networks":
“There was a database error fetching the model version information from your database. [There was a database error fetching the model version information from your database.]Java.lang.IllegalStateException: The main connection to the datastore has not been initialized; check your WmTN packages startup service.
Error initializing the datastore: There was a database error fetching the model version information from your database.”

Now, I went to the Admin tool via the browser, clicked on JDBC POOLS and saw that there where no “Alias Pool definitions”, I tried to create one for TN (Trading Networks Function) with the following specifications:
“Alias Name: TN
Alias Description: TN
Associated Driver Alias: DataDirect Connect JDBC Oracle
Database URL:;SID=WEBM;
User Id: ******
Password: *******
Minimum Connections: 10
Maximum Connections: 250
Idle Timeout milliseconds: 60000”

When I’m restarting, I still get the error. When I’m in the Admin console in the browser, going to JDBC Pools, pressing Test at TN, I’m getting:“Test of TN Failed No suitable driver”.

What do I need to change to make this work?

Thank you very much, regards,

Mario Rave

Pls try also with Merant sequelink Driver (Preferred)…

Alias Name:TN
Alias Description:TN
JDBC Driver:com.merant.sequelink.jdbc.SequeLinkDriver

Database URL:jdbc:sequelink://yourIP:19996;databaseName=WmTN;
User Id:xxx
Password :xxx
Minimum Connections 10
Maximum Connections 250
Idle Timeout milliseconds 18000


I’m trying to plan a migration off Cloudscape to Oracle with an IS/TN v4.6 on a Unix box. The webMethods documentation is giving me some conflicting advice.

  1. Can webMethods (any component: EAI server, adapters, brokers, or even IS server) reliably run on the same box as SequeLink Server?

  2. Do I need SequeLink Server if I use a JDBC type 4 driver? I know v4.6 doesn’t come with the type 4 driver, but webMethods support hinted toward pulling it from the install of v6.0.1

  3. Is using Logger Adapter a valid, reliable, and a forward looking plan? We do plan to upgrade to v6.0.1, but not for at least a year. We have our EAI environment already using the Logger Adapter with SequeLink, which makes things a simpler.

  4. webMethods support also suggested using the v6.0.1 database data migration scripts (which will include all data: acitivity log, transaction data, profile data, certificates …) Has anyone successfully migrated a v4.6 Cloudscape data to an external database using v6.0.1 migration scripts? Are there any pitfalls I need to be aware of?

And I guess in general … any advice on migrating from a Trading Networks build-in (Cloudscape) database to an exteranal Oracle 8i database.

Any help would be much appreciated!


how can I connect using sap bc to a sql 7 db on another machine. Cannot connect due to unsuitable driver!
db;databaseName=timelogDB Driver:
Alias: mytest
Password: ******

what am I doing wrong? can any one assist please, 1st time using the DB

Do you have the sequel server driver installed? Did you try to connect using the default driver sun.jdbc.odbc.JdbcOdbcDriver?
Please let us know.

no checked and seen that there are no drivers installed - where should this have occurred.