The command _XQL(1,1) is not supported

Hi,

we have an application based on tamino server 3.1.2.1. Request like ‘?_XQL(1,1)=’ are freequently used. Now we are migrating to Tamino 4.4.1 which gives the following result:

[b] <?xml version="1.0" encoding="ISO-8859-1" ?>

Is tamino 4.4.1 not backward-compatible or are there any other reasons?

Could you please check replacing the

‘(’ with ‘[’ and
‘)’ with ‘]’

so that your queries take the following form

?_xql[1,1]=

Hope this helps.

Thanks,
Srinu

Oh yes, I tried, but what I got was about a million documents - not only the first one. You could imagine how my machine was hanging?

The next problem is: Just if this worked - these queries are hard-coded in an application that is running stable on Tamino 3.1.2.1 since years. Now we’re migrating to Windows XP and it seems like we won’t get a XP-licence key. No way to make Tamino backward-compatible and not touching a correctly designed application? My customor will not be amused if he has to pay for any drawbacks.

:arrow: What if Microsoft decides not to support ‘’ on the file system - would billions of developers have to migrate their up to thirty years well running software?

:twisted: Yeah - I think we’ll keep on working with W2K and 3.1.2.1 since this problem may not be the only drawback

The old style cursoring (e.g. _xql(1,1)) feature has been removed from Tamino v4.4. The application needs to be changed to use the new style cursoring as described in the Tamino documentation.

Hope this helps.