The application needs to click twice button login

When I run the CAF application from the root node, it opens the “login” view, but when I introduce the user and the password in this view, and I click the button (commandButton) it seems that the view doesn’t do anything just refresh itself without sends anything to the server, so I have to introduce the information twice, and this second time it works correctly.
It only occurs in this view.

From your description, it sounds like you are deploying a CAF Web Application to an Application Server. If so, which App server are you deploying to? Additionally, what version of CAF are you using?

In 8.0.1, we’ve fixed some issues in the generation of the web.xml file. The default security settings needed some changes. However, it doesn’t sound like this is the problem since you are eventually able to authenticate.

FWIW: You might have a look at the 8.x CAF Designer help to review the security settings for CAF and other app servers.


I am deploying to WebSphere Application Server 7 or Tomcat 5.5, in both is the same.
We are using webMethods 7.1.3.
This login view uses the acegisecurity to do the authentication.
Thanks in advance

Is it possible to use FireBug to determine whether the initial click is causing a Form Submit, and whether the request is going to the server?

I have done the view again and now it works correctly, thanks for your attention