Tamino Servlet Error

Hi,

I am able retreive data from Tamino using query like this

]http://localhost/tamino/RealEstate/Property?_xql=/Property[@PropertyReference=‘CASAN00001’]

I am able retreive xsl from Tamino using query like this

http://localhost/tamino/RealEstate/mycol/xsl:stylesheet/@1

If i am giving query like this

http://localhost/servlets/styler/tamino/RealEstate/Property?_xql(1,10)=Property&_xslsrc=http://localhost/tamino/RealEstate/mycol/xsl:stylesheet/@1

getting error like this

Tamino Servlet Error.

I register alias in zone file like this
servlet.styler.code=com.softwareag.tamino.api.servlet.TaminoFilter

What wrong in my query.Please tell me how to make query to work.Please help me in this regard.

thanks
Srinivas.

srinivas

Hi,
I suppose your servlet environment settings are not right. Please check the jserv.propertie file.
The servelt expect the classpath environment below.

wrapper.classpath=[path]\passthru.jar
wrapper.classpath=[path]\xt.jar
wrapper.classpath=[path]\xp.jar
wrapper.classpath=[path]\sax.jar

Hi,

ThanQ for your reply.

I given classpath in jserv config file like this

wrapper.classpath=C:\Program Files\Apache JServ 1.1.2\ApacheJServ.jar
wrapper.classpath=C:\Program Files\Jsdk\lib\jsdk.jar
wrapper.classpath=C:\Program Files\Apache JServ 1.1.2\servlets\passthru.jar
wrapper.classpath=C:\Program Files\sree\xt.jar
wrapper.classpath=C:\Program Files\sree\xp.jar
wrapper.classpath=C:\Program Files\sree\sax.jar

and i given alias name in zone file like this

servlet.styler.code=com.softwareag.tamino.api.servlet.TaminoFilter

If servlet envoronment is not set,test servlet shouldn’t work.But test servlet working fine.

The log file having this
[06/12/2001 12:01:46:483 GMT+05:30] sri/com.softwareag.tamino.api.servlet.TaminoTest: init
[06/12/2001 12:04:45:811 GMT+05:30] styler/com.softwareag.tamino.api.servlet.TaminoFilter: init
[06/12/2001 12:04:45:811 GMT+05:30] styler/com.softwareag.tamino.api.servlet.TaminoFilter: (i) List of all knwon servlet init args:
[06/12/2001 12:04:45:811 GMT+05:30] styler/com.softwareag.tamino.api.servlet.TaminoFilter: (i) list finished ---------

The server log file like this
[Thu Dec 06 14:18:45 2001] [notice] Handler ino(v1.30.1.1): successfully initialized
[Thu Dec 06 14:23:44 2001] [error] (2)No such file or directory: Handler ino(v1.30.1.1): gethostbyname failed.

It is failed at Filter class.

Please check this and give sugessitions to overcome this.

thanks
Srinivas

srinivas

Hi,
looks like a problem with your domain name.
The servlet translate the local host name into a domain host name. Maybe anything goes wrong with your machine.
This calls should be working fine, find it out.
http://localhost/servlets/styler/tamino/RealEstate/Property?_xql[1,10)=Property

http://localhost/servlets/styler/tamino/RealEstate/mycol/xsl:stylesheet/@1

and the same calls with your pc name instead of the localhost name.

Hi

Thanks for your reply.
I tried with the above url.But same error repeating.It is like below

Tamino Servlet Error
Pass Thru Version: 2.1.1.1.1

Message Text: hs

Methode : GET

Pathinfo : /tamino/RealEstate/trail

QueryString : _xql(1,10)=trail&_xslsrc=Comp/xsl:stylesheet/@1

Server name : hs:80

Headers

accept-language:en-us

host:localhost

accept:image/gif, image/x-xbitmap, image/jpeg, image/pjpeg, application/vnd.ms-excel, application/msword, application/vnd.ms-powerpoint, /

user-agent:Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.0)

connection:Keep-Alive

accept-encoding:gzip, deflate


But test servlet working fine.

How to overcome this.

thanks
Srinivas

srinivas

QueryString :
_xql(1,10)=trail&_xslsrc=Comp/xsl:stylesheet/@1

This is not the same example as above. (confusing)

The new example is using a relative XSL reference
For this to work you must have the style sheet doctype in the SAME collection as the target document.

I recommend creating an xsl:stylesheet doctype
in the same collection (trail?)
and the query

http://yourComputer/servlets/styler/tamino/RealEstate/trail?_xql(1,10)=Property&_xslsrc=xsl:stylesheet/@1

Hi,

I am trying with three samples.

The url without “servlets/styler” is working fine.
http://localhost/tamino/RealEstate/mycol/xsl:stylesheet/@1

http://localhost/tamino/RealEstate/Property?_xql(1,10)=Property

Once i inserted servlets/styler the each individual urls also not working.

But http://localhost/servlets/com.softwareag.tamino.api.servlet.TaminoTest is working fine.

May be problem with the “styler”.It is not invoking concerned object.

While giving the url

http://localhost/servlets/com.softwareag.tamino.api.servlet.TaminoFilter

it is giving Tamino Servlet Error.

In Jservlog like this

[08/12/2001 09:05:55:085 GMT+05:30] com.softwareag.tamino.api.servlet.TaminoFilter: init
[08/12/2001 09:05:55:085 GMT+05:30] com.softwareag.tamino.api.servlet.TaminoFilter: (i) List of all knwon servlet init args:
[08/12/2001 09:05:55:085 GMT+05:30] com.softwareag.tamino.api.servlet.TaminoFilter: (i) list finished ---------

Please letme know if you got any solution for this.

thanks
Srinivas

srinivas

Hi,
please check your zone.properties file.
The servelt expect a lot of init arguments. Please compare the entries below against your zone.properties entries.

servlet.styler.code=com.softwareag.tamino.api.servlet.TaminoFilter

# Init the content type of the response document
servlet.styler.initArgs=contenttype=text/xml
# Switch the stylesheet cache on respectively off .
servlet.styler.initArgs=cache=on
# The init cache size value
servlet.styler.initArgs=cachesize=200

# Runs Jserv as a stand alone application then the tracer printed a trace information into the command window.
servlet.styler.initArgs=trace=off

#This writes log information into the log file.
servlet.styler.initArgs=log=off

Hi,

I changed setting what you said above.But it is still giving same error.

1.It is giving error while running TaminoFilter class.

http://localhost/servlet/com.softwareag.tamino.api.servlet.TaminoFilter/tamino/RealEstate/Property?_xql(1,10)=Property

The above url is itself not working.

But the both URLs given below working fine.

http://localhost/tamino/RealEstate/Property?_xql(1,10)=Property

http://localhost/servlets/com.softwareag.tamino.api.servlet.TaminoTest


If i give the url like this

http://localhost/servlet/styler/tamino/RealEstate/Property?_xql(1,10)=Property

It is giving error like this
html>
-
Tamino Servlet Error

-

Tamino Servlet Error


Pass Thru Version: 2.1.1.1.1


Message Text: null


Methode : GET


Pathinfo : /tamino/RealEstate/Property


QueryString : _xql(1,20)=Property


Server name : hps:80


Headers


accept-language:en-us


host:localhost


accept:image/gif, image/x-xbitmap, image/jpeg, image/pjpeg, application/vnd.ms-excel, application/msword, application/vnd.ms-powerpoint, /


user-agent:Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.0)


connection:Keep-Alive


accept-encoding:gzip, deflate




I think it may be a problem with Filter class only.Please choose solution for this.

thanks
Srinivas.

srinivas

[This message was edited by B.Srinivas on 03 Jan 2002 at 04:48.]

Hi,

for TaminoTest you used
http://localhost/servlets
/com.softwareag.tamino.api.servlet.TaminoTest…,
for TaminoFilter you used
http://localhost/servlet
/com.softwareag.tamino.api.servlet.TaminoFilter…

Does the url http://localhost/servlets/com.softwareag.tamino.api.servlet.TaminoFilter/tamino/RealEstate/Property?_xql(1,10)=Property work?

What happens if you use the proper hostname instead of localhost?

Best Regards
Christine