Strange performance problems (possible solution)

Hi list members !

Seems that I discoverd the reason why the database performance varies heavily on different computers. It’s simply a matter of differences in database content. I did not recognize that for a long time, because the difference is quite small. We are working with big sized documents containing graphical information (around 1 to 2MB). A test showed that adding further data to a 1.6MB document leads to really bad query performance. While the query time using the original document (1.6MB) is less than 1 second, adding one graphical object (254Kb) to the document leads to 45 seconds query time and adding another instance of the same object to 212 seconds. So it looks like that Tamino has some kind of limit regarding document size. Are there any database settings in Tamino to improve the processing time of big sized documents ?

Another strange effect I found during the test, is that the following two queries differ heavily in performance, although they deliver almost the same results:

Query 1:
--------
for $a in input()/SpatialContainer/children/
return {$a/@id}

Query 2:
--------
for $a in input()/SpatialContainer/children/

return $a/@id

While Query 1 runs for 212 seconds, Query 2 runs in less than 1 second. Does anyone have an explanation for this ? (There are about 500 objects in /SpatialContainer/children/)

Thanks,
Werner.

Hello,
eventually the internal XQuery document cache
(Property: XQuery document cache size )
needs to be enlarged.
Note in V4.2 the cache managment has been improved.


Best regards
Walter

Hello Walter, thanks for your answer !

Where do I find this property ?
I’ve looked for it in Tamino manager and in the documentation without luck.

Will V4.2 be available as “XML Starter Kit” in the near future ? Currently we are using V4.1.4.

Thanks again,
Werner.

Meanwhile, I found the answer on the forum.

It’s a registry key.

[HKEY_LOCAL_MACHINE\SOFTWARE\Software AG\Tamino\servers\test\server parameters]
“XQuery_document_cache_size”="100"

Setting the XQuery cache size to 100MB improved query speed by magnitudes !

Thanks,
Werner.