Startup hangs after move to behind firewall

We’re running Integration Server 9.6. Yesterday, we moved our development AIX server to a new network which is behind a firewall for all access (internal hosts and internet hosts are blocked by default). Now, IS will not start.

It prints these three lines to the log, and nothing further:
2016-04-21 12:44:07 EDT [ISS.0025.0001C] Integration Server Build 294
2016-04-21 12:44:07 EDT [ISS.0025.0006I] License Manager started
2016-04-21 12:44:08 EDT [ISS.0025.0049I] The JCE Unlimited Strength Jurisdiction Policy File was found

I have gone so far as to do a completely clean, fresh install. Same exact symptom. Analysis of a thread dump shows two threads on the dev server which don’t have matches on our functioning non-firewalled QA server:


Any guidance on how to troubleshoot this? I can’t seem to get a blip of information from any log files hinting at what the problem might be. Our firewall admin insists he doesn’t see any outbound connection requests from the machine during startup.

Verify that it takes long time to execute "netstat -a " command on the machine which hosts Integration Server.

Disabling the /etc/resolv.conf will ensure that both the netstat -a execution time and the Integration Server startup time revert back to their normal values.

As you suspected, “netstat -a” does hang part way through displaying output. I’ve engaged our UNIX and networking support to troubleshoot.

Confirmed - once both UDP53 and TCP53 were allowed through the firewall, server startup worked fine.

Great, that worked and I am glad to hear.