Starting a Process with an InfoPath E-Form

I have my webMethods and Integration Server configured correctly to accept an InfoPath form schema as input.

  • I’ve also tested the process in webMethods Developer and it works ok. I’ve setup my E-Form repository instance including template folders and uploaded my documents.
    I’ve added an environment in the integration server to map the eForms environment to the eForm repository

What I didn’t see in the documentation for Implementing the E-Form support for BPM Version 8.0 documentation was the submission process. For an infopath form or an Adobe Form, where should the submit location of the form be set to.

Thanks in advance

Hi Richard,

When you set up your e-form environment in MWS you should have specified a value for “Server Listening Path”. That folder, in MWS, is where you should place instances of your e-form.

A picture showing where that is specified may help here so take a look at the attached serverlisteningpath.jpg.

The following may also help; pages 26-29 of my copy of the documentation for “Implementing the E-Form Support for BPM” discuss configuring your environment. And buried in there the “Server Listening Path” is discussed (snipped here for your convenience):

  Server Listening Path—the path to the e-form folder that will contain [b]the instances that will be used to start a new business process[/b]. For example, if you are using My webMethods Server as your repository, with an Instances folder in Public Folders, the path would be /Public Folders/Instances. This field has a character limit of 1024.

I hope that helps.

Mike thanks for the response. I’ve gone through those steps and setup the environment according to the documentation, but when I add files to the implementation folder nothing happens. The process doesn’t run.

If I run the process from within the webMethods designer it works and the process runs.

I’ve attached the relevant screenshots.


Here the e-forms configuration information for the E-forms server.

If I understand correctly the process engine polls the e-form instance folder for changes / additions like new documents adhering to the schema. When it see’s them it should execute the process that was mapped in the environment.

I’m thinking there might be another step that’s missing. How can you validate the polling is happening? Is there a log to check. How can I verify the process engine is doing it’s job and perhaps failing.

Perhaps the process engine environment configuration is missing something?

As a possible cause of the problem which I’m not sure how to change

I am looking at the WmPRT process Engine Startup messages and what I see is the following error

“Unable to change listener please disable all other models currently using this listener:”

How can I remove processes from the process engine. I don’t see a link to do that readily.

Hi Richard,

Those screen shots look correct, which is a good thing.

You are correct that the process engine, PE, polls the e-form instances folder for additions. You can check PE status via the PE “dashboard”. The dashboard is accessible via the IS Admin page under Packages / Management, wherein you would click on the “home” icon in the WmPRT row. Once the PE dashboard comes up, then you can click on “Startup Messages” to get a general idea of any startup issues. And for specific process information you should click on “Process” and then click on your specific process name. The right pane should indicate the status of various items, one of which is the Listener.

That said, let me ask about two broad setup items: I) did you update the password to match your environment, and II) are you placing an actual instance of your e-form into your defined instance folder?

In greater detail:

I) Did you update the password to match your environment?
Your screen3.jpg shows what appears to be a successfully-deployed ContactInformation_Forms_Environment. And screen1.jpg shows it being used. In screen2.jpg 1) did you replace the password in the “Server Password” field with the correct value, and 2) did you click Save therein?

II) Are you placing an actual instance of your e-form into your defined instance folder?

  1. In the screen2.jpg you have defined /Public Folders/InfoPath/Instances/ContactInformati…
    Is that the folder in MWS where you are actually placing your InfoPath instances?
  2. The instance for InfoPath must have an .xml suffix. Does your instance include that?

I realize that some of the above questions may seem obvious and silly, and I apologize for that.

Hi Richard,

One way that you can disable all other models is done in MWS per the attached processdisable.jpg. Click on Business Processes.

Some additional information:

  1. I’ve been manually uploading XML files to the public instance folder with the .xml extension
  2. I confirmed the password is correct.
  3. In the process information on the screen shot you showed. I see in that area I have three processes that I want to delete, but they are greyed out and won’t allow it. Is there another way to delete them? Attached image
  4. I confirmed the save password for the e-forms environment.

I see a new message today though

In the Process Engine WmPRT (Process Engine > Startup Messages)

[MID=HelloWorld/InfoPathContactInformationLogger] Listener for e-Forms at path: “/Public Folders/InfoPath/Instances/ContactInformation/” has been disabled from jcr

I think there is something possibly wrong with my processes in MyWeb methods but I don’t see a way to kill them. If I can and republish maybe this problem will go away.

Thanks for all of your help.

Here are the last 2 screen shots that I had problems attaching to the last message

Hi Richard, as I understand it, the reason you cannot delete the processes is that you have used them, i.e. you have run them and therefore created instances of them.

A thought would be to just create a new process.

To keep things clean create a new e-forms environment. Your new process could be triggered by the same e-form-associated IS doc type.

I tried creating a new simple process with one flow service that is initiated by an InfoPath eForm. The process works in debug mode using the webMethods designer and developer tools, but when I add instances to the instances folder nothing seems to happen.

Is there anyway to confirm that the triggers/subscriptions for these are working correctly? It says it’s listening to the folder for instances.

Is there a way I can quickly confirm that the subscription/listening processes is working even for other types of documents? Is there an easy way to submit the same type of document directly to the broker that would invoke the same process?

Trying to see if there is a way to isolate where the problem is.

I think the problem is our broker server isn’t running correctly or not correctly configured within my webMethods. I’ll work on this part. Thanks for your help

Richard, glad you tracked it down!

I had this similiar problem, finally I found solution