SSL - Change_Cipher_Spec

we have a testenvironment with an IS (6.0.1, SP1) that runs a C1Onramp (3.0, SP1). This all is running under Win2000.

When I trie to send documents via HTTPS to a C1 MarketSite (4.1) I sometimes get an error: not hs_change_ciphersepec

Im not quit shure what the reason for this error could be. If its a problem of the certificate on the IS it would happen every time I send a document from the IS to C1-MarketSite.
When the error occurs the system is not verry busy.

But to be shure that I don`t miss to check any possible reason, I have tried to install certificates from the same CA that the C1-MarketSite uses. It is an Authority with an intermediate Certificate. And there begins the next trouble:
I have installed the servercertificate, the intermediate-CA and the key in the “Outbound SSL Certificates”. The CA (top level) is installed under Trusted Certificates (all under Security/Certificates). But when I trie to establish a connection from C1Onramp to MS I get an error: Server certificate rejected by ChainVerifier.
Has someone an idea how these two problems can be solved?

Regards Sascha Imhaeuser