[SOLVED] User Task Action doesn't assign value

Hi everybody,

I’ve got a user task set up in my project for the approval process of an enrollment. But when an enrollment is queued and I press the approve button, it doesn’t assign a value.

In the image below you can see the configuration for the action.

First it should assign ‘Y’ to the (string) field that indicates approval or denial and after that I complete the task. The task gets completed but the value doesn’t get assigned. I’ve done it the same way as described in my BPM Developer’s guide.

Does anyone know why the value doesn’t get assigned?

With kind regards and thanks in advance.

The altered document was set under a Task Data document, after mapping this Task Data to my original document the changes were there.

In the java code of this action, can you find the similar code below?

resolveDataBinding(*ACTION_PROPERTY_BINDINGS, this, "*Action", true, false);
public String approve() {
	    resolveDataBinding(APPROVE_PROPERTY_BINDINGS, this, "approve.this", true, false);
		return OUTCOME_OK;

This is the java code of the action

Hi Kevin,

I noticed that the subject changed to [SOLVED], is that true? How do you fix it?

In the User Task in my process the changed value was mapped under a document called TaskData. So in the output of that Task, after clicking on the right ‘Edit Data Mapping’ on the inputs/outputs tab, I mapped the document under the TaskData document to the Document that I use in the pipeline. After that it worked.