[SOLVED] [PRT.0101.9433] Gateway has no live outputs.

Hi everybody

I am experiencing the above error at the moment and I have no clue what causes it. In my process I have another gateway without any in-/outputs which works fine. But this gateway doesn’t seem to work even though I have set different combinations as in- and outputs.

This gateway checks if a User Task is either completed or cancelled with that Task’s TaskCompletionInfo/status.

Below an image to clarify my situation.

The ‘Is completed?’ gateway is the one where I’m getting the above error, the ‘Is approved?’ gateway is the one I mentioned that doesn’t have any in-/outputs.

If anything is still unclear or if I have forgotten any information please don’t hesitate to ask.

With kind regards


Ok, maybe the problem can be found here?

These are the in-/outputs I currently have for the gateway:

And this is the pipeline data for that gateway when debugging (if I add a default path to it, otherwise it fails and I can’t view the pipeline for that step):

I found the solution while developing a workaround for the issue. The User Task before the gateway wasn’t mapping the TaskCompletionInfo to the ‘Send Reminder and Cancel CourseRequestOutputEnv’ document.

After manually mapping these two documents everything worked fine.

Hopefully anyone will find this useful :stuck_out_tongue:

Kind regards

1 Like