soapHTTP Fails with Conection timed out.

Hi All,

We’ve WM 6.5 product suit and wants to interact with .Net application using webservices.

I created webservice connector using WSDL provided by .Net developer. Problem I’m having is when I try to invoke this connector from other service after a long wait (more than 15-20 mins I guess) it fails at the step pub.client:soapHTTP with error Connection timed out. I’m finding it hard to understand why is it failing.

I tried telnet from IS to IIS and back to make sure that http traffic is flowing fine between them (There is a firewall in between which is configured to allow traffic on port 80).

Appreciate if you can help me solve this problem, as this is turning in to the show stopper for us.




What happens when you attempt to invoke the .Net service using one of the many soap testing tools such as SOAP Sonar, PocketSOAP TCPTrace, XML Spy Enterprise etc.?


Hi Mark,

I’ve just downloaded SOAP Sonar. Will give it a shot and get back here.

Also some additional info. I tried doing pub.client:http with the URL (hosting webservice) and that hangs too. However when I created a blah.html containing only some junk strings in there and put it in the same web directory/folder where this .Net webserivice is hosted it comes back in fraction of second.

Don’t know if above information adds any value.



I Build up request file for SOAP request from SOAPSonar, and I realised that my Dev PC doesn’t have access to the webservice host and only my WM server do. Then WM is hosted on Linux and can’t install SOAPSonar there…

Guys any other alternate.



Hi Mark, and All

Thanks a lot for your tip. Apparently we figured that it was a firewall problem. It was not properly configured to handle HTTP Post request so HTTP get worked but not Post.

Thanks also for letting me know some of this tools for web services. They will definitely help me in my work in the future.