SOAP WSDL not connection to Sharepoint Info Path

I have created a soap webservice using 8.2 wm. I am able to consume the service internally fine, works fine with soap UI. but does not work with sharepoint infopath 2010. When infopath tries to consume the wsdl it throws an error saying “Access Denied and invalid xml”

Has anyone faced this issue in past? Can someone help regarding this issue?

Did you check the ACL permissions/firewall ip blocking on the service from the sharepoint site from externally endpoint??

If soapUI works then what’s the different are they you trying?


Acls are set to anonymous at the service level. The difference is we can consume the service with SOAP UI but when Microsoft InfoPath tries to connect it does not work, checked the firewall settings, at this point I don’t think it is firewall blocking it, because the error we are getting says “invalid xml access denied”. InfoPath has to read the xml to know it is invalid file. Resource at SAG support tried to use some random wsdl file with InfoPath and got the same error that we are getting.

Note: the service works fine when it is consumed internally from a different integreation server and as mentioned above works fine with SOAP UI.