SOAP Response Error

Hi,

I have been trying to send SOAP messages from webMethods to specific Interfaces but I am getting the following error after using the Webservices.

Server was unable to read request. → There is an error in XML document (6, 4). → ‘’, hexadecimal value 0x11, is an invalid character. Line 6, position 20.

I have tried manipulating the XML Data as well as trying with separate XML Data but for every data it is showing the same error.

Can you please provide the solution to this problem.

When you call pub.xml:documentToXMLString set “encode” to true.

But the root question you may want to investigate is why there is an 0x11 character in the data? That doesn’t seem typical for XML data.

<faultcode>soapenv:Client</faultcode>
<faultstring>An invalid XML character (Unicode: 0x1d) was found in the element content of the document.</faultstring>

I get the above error when foreign characters are sent to the client.
Any suggestion on how to handle these ?

Any idea ?

Did you try setting the encode variable in the call to documentToXMLString?

Yes. That did not help.
I was going through another forum
http://forums.pentaho.org/archive/index.php/t-51962.html
where some people encountered the same error and someone has mentioned about base64encode.
I am not sure if that is the right path.