SOAP invocation error

Hi everybody,
In my project we have a web application that access to webmethods services using SOAP invocation.

This is our webMethods Integration Server|
Version : 9.6.0.0|
Updates : IS_9.6_Core_Fix2|
Build Number : 294

Recently we have to updated the truststore and keystore certification files, but when we tried to access to the server we get the following error

2022-04-27 16:52:41,603 ERROR e.i.s.m.controller.GestorConsultasController
org.springframework.ws.client.WebServiceIOException: I/O error: Connection reset; nested exception is java.net.SocketException: Connection reset at org.springframework.ws.client.core.WebServiceTemplate.sendAndReceive(WebServiceTemplate.java:561)

When I check the server log in the I.S, there’s always the same error.

java.lang.NullPointerException: null
at com.wm.app.b2b.server.HTTPState.getBasicAuthenticatedUser(HTTPState.java:848)
at com.wm.app.b2b.server.HTTPState.getAuthenticatedUser(HTTPState.java:810)
at com.wm.app.b2b.server.HTTPState.processHeader(HTTPState.java:254)
at com.wm.app.b2b.server.Dispatch.processHeader(Dispatch.java:269)
at com.wm.app.b2b.server.Dispatch.run(Dispatch.java:366)
at com.wm.util.pool.PooledThread.run(PooledThread.java:127)
at java.lang.Thread.run(Thread.java:744)

I’m looking for this error by tech forum, and I’ve found a similar error

probably, the problem is the request loses the authorization header as explain in the post, but I haven’t any idea how to resolve it.

Here is a bit piece of our request invocation:

request = {SaajSoapMessage@15125} "SaajSoapMessage"
 messageFactory = {SOAPMessageFactory1_1Impl@15069} 
  listener = null
  lazyAttachments = false
 saajMessage = {Message1_1Impl@15132} 
  headers = {MimeHeaders@15133} 
   headers = {Vector@15137}  size = 2
    0 = {MimeHeader@15139} 
     name = "Accept"
     value = "text/xml, text/html, image/gif, image/jpeg, *; q=.2, */*; q=.2"
    1 = {MimeHeader@15140} 
     name = "SOAPAction"
     value = """"
  contentType = {ContentType@15134} "null"
   primaryType = null
   subType = null
   list = null
  soapPartImpl = {SOAPPart1_1Impl@15135} 
   headers = {MimeHeaders@15148} 
    headers = {Vector@15153}  size = 1
     0 = {MimeHeader@15155} 
      name = "Content-Type"
      value = "text/xml"
   envelope = {Envelope1_1Impl@15149} "[SOAP-ENV:Envelope: null]"
    header = null
    body = {Body1_1Impl@15158} "[SOAP-ENV:Body: null]"
    omitXmlDecl = "yes"
    charset = "utf-8"
    xmlDecl = null
    encodingStyleAttribute = {ElementImpl$AttributeManager@15161} 
    elementQName = {QName@15162} "{http://schemas.xmlsoap.org/soap/envelope/}Envelope"
    namespaceURI = "http://schemas.xmlsoap.org/soap/envelope/"
    localName = "Envelope"
    type = null
    name = "SOAP-ENV:Envelope"
    attributes = {AttributeMap@15166} 
    ownerDocument = {SOAPDocumentImpl@15150} "[#document: null]"
    firstChild = {Header1_1Impl@15167} "[SOAP-ENV:Header: null]"
    fNodeListCache = null
    fBufferStr = null
    previousSibling = {Envelope1_1Impl@15149} "[SOAP-ENV:Envelope: null]"
    nextSibling = null
    ownerNode = {SOAPDocumentImpl@15150} "[#document: null]"
    flags = 24

If we invoke the services by SoapUI, it works correctly and send us the expected results

> HTTP/1.1 200 OK
> Set-Cookie: ssnid=cc442d809cbb1d9daba6c18ac669dd4d; path=/; HttpOnly
> Content-Type: text/xml; charset=UTF-8
> Content-Length: 677
> <?xml version='1.0' encoding='UTF-8'?><soapenv:Envelope xmlns:soapenv="http://schemas.xmlsoap.org/soap/envelope/"><soapenv:Body><ns:expediente xmlns:ns="http://provincia.consultas.ws.mdage.sgtic.ine.es"><cabecera><codigo>00000000202204211601803CONPRINE</codigo></cabecera><detalleRespuesta><datos><provincia><idPro>1100000028</idPro><cpro>28</cpro><dprov>MADRID</dprov><estado>0</estado><validoDesde>19000101</validoDesde><fAltaBD>20161018</fAltaBD></provincia></datos><mensajes><mensaje><codigo>OK</codigo><descripcion>Registros encontrados con los criterios seleccionados</descripcion></mensaje></mensajes></detalleRespuesta></ns:expediente></soapenv:Body></soapenv:Envelope>

Could you help us?

Thanks
Best Regards
José Pascual

Hi Jose Pasqual. You are 20 fixes behind! Please upgrade to the latest fix level - IS_9.6_Core_Fix22 - and this problem will go away.

Regards,
Michael

Thanks Michael,
we’ll install the latests fixes in our system.

Thanks a lot.
Regards
Jose Pascual