Soap Header Error

Getting this error “;[Lcom/wm/lang/websvc/WSHeader;Ljava/lang/String;)Lcom/wm/data/IData;” when calling a third party web service.

The webservice does not require a header be send or does it return one on the call. I ran the web service through Oxygen and verfied there is not header being returned. Could no header in the response be causing the error? The Application support person can see the records I send over being posted in there database.

I am using the SOAP Client (pub.client.soapClient) service to send data to the web Service. I am on 7.1.2.

hi nesabo,

i get the same error while calling an third party webservice via soapclient. which core and server protocol fixpacks have you installet. i mentioned the error when we moved from core fix 9 to 12 and serverprotocol fix 7 to 11. perhaps it has something to do with this, but i’m not sure.



I am also facing the same issue …


Please let us know all the possible solutions.


did anybody find a solution for this? we are having the same exact issue…

I have in two different environments and it work just fine in DEV, but in QA we get that error…

Thanks in advance,