SmartREST template doesn't apply

I have a custom template with id 222.
I have created a new device MQTTBoxDevice using MQTTBox.
I subscribed the error topic s/e

I tried to send message 222,45
And I received error message: “40,222,No static template for this message id”

I tried to create template 10,333,POST,MEASUREMENT,c8y_TemperatureMeasurement,c8y_TemperatureMeasurement.T.value,NUMBER,
But I received folow message agan: “40,10,No static template for this message id”

At the same time a static template (for example 211) works well.

Why is Cumulocity trying to find a static template instead of my own template?
Why can’t Cumulocity find a static template 10?
How can I create template and send message using this template?

Hi Alexander,

to use custom templates instead of static templates you need to address them in the mqtt topic.

Please see https://cumulocity.com/guides/device-sdk/mqtt#smartrest-2 for more informations on that.

The standard topic you should use is s/uc/
where is replaced with your template’s ID.

best regards
Michael

Thank you!

It is working.