SelectRowCheckbox object on Async table

I am a new CAF coder and very unfamiliar with Java…I’m pulling in an IS service to a portlet, and results are being displayed in an Async table. No problem. I’ve added a column to the table, and I’ve added a SelectRowCheckbox object in the column. The objective here is to have users select rows they wish to process.
When I run this, the column appears, but the checkboxes don’t…so I can’t get them to “work”. Searching through the forum, I’ve found entries that imply the Async table - or the IS service results set?? - need to be bound to an “updateable table” or “updateable table result provider”.
When I try to research these things further, I’m repeatedly referred to the now defunct softwareag ajax site!
Can someone tell me what either or both of those are? And how does the binding work? Other posts indicate that I will need to write a java class…to do what???
Thanks for any and all help.

Hi
have a look at the samples in
http://communities.softwareag.com/ecosystem/communities/public/Developer/webmethods/products/caf/tutorials/caf_tutorials.html
and
http://communities.softwareag.com/ecosystem/communities/public/developer/webmethods/tutorials/CAF/webMethodsSamples80_OC.html?overview=/public/developer/webmethods/products/CAF/Tutorials/index.html&overview-page=1

I believe you’ll find the needed info there.
best regards,
Javier

Thank you! The references you’ve supplied have given me a few things to try…

I’ve been able to get one of the samples working, but in my environment things are a bit different. First, I’m not writing a web application, but I’m working on a portlet, so I’m unsure if that makes a difference.
The original table is generated from an IS service - it is the Async Table that is generated and displayed from the IS service. I was successful in getting this output linked to a content provider so I can now see and use the select row objects on the web page, which is good. However, I can’t successfully map selected records to another Async table or even a dump. I get a ClassCastException when trying to move the selected rows to another table (per the sample code and instructions). The final destination table (of selected rows) has a java type of com.webmethods.caf.MySelectedClass; the original Async table bean from the IS service is not this java type…

Is that causing the error? And and how do I get the data from an IS service mapped through a Content Provider to another table?

Any advice would be greatly appreciated!

Hi Jocelyn,
I hope my answer in the other post can help you on this.
There are no differences between working with webapp views or working with portlets (at least not in the area you mean).

One other thing… whenever you generate a Content Provider from an array/list of objects, and you want to add items to that content provider, you need to remove the binding from the Source List/Array of the content provider. Otherwise you’ll have two “sources” for the content provider (one coming from the browser, the other coming from the Source List/Array), and only one can “survive” (the Source List/Array Bindings).

Once you remove that binding, you’ll need to:

  • Map your array of items to the Content Provider’s Source List/Array in the Initialize action.
    When you want to use again the array of items (when leaving the page, when using it as input for a service…) you need to map back the Content Provider’s Source List/Array to your array of times.

It is kind of confusing, but I hope I managed to explain it well enough.

best regards,
Javier

Hi Jocelyn,

I am experiencing the same difficulties that you’ve been through with this topic. I’m sure you finally got it working… Can you please help me understand a few thing…

I am wanting to select a few rows from a table in my view (displayed via a content provider using an updatable table with selection).
My data is displayed okay - the row selection checkbox are inserted okay

I have a web service that is supposed to insert selected rows into a database table - I tested the flow service manually - data is inserted into my table…

I also created an action but I’m struggling with the data flow implementation - I tried all sorts of assignments but to no avail…

My row id expression is assigned but I just can’t get this thing to work.

Any help from anyone out there will be most appreciated.

Kind regards
Vikash