SBL-EAI-04313 - Error in calling webService on Siebel

We have wsdl from our customer from Siebel server and created a web service connector through developer 6.1. When we run the service with the proper SOAP request we are getting the following error.

[0] There is no active Web Service with operation named ‘’.(SBL-EAI-04313) (IDS_EAI_WS_OP_NOT_FOUND)

There is no active Web Service with operation named ‘’.(SBL-EAI-04313)

But with a simple Java client and XMLSpy tool we are able to get a SOAP response successfully. The above error is also arising from the XRay tool.

We have tried with various options but nothing worked out till now. As of now we have also opened a SR with Siebel support team to see if the issue is from Siebel side. Any help would be greately appreciated.


Sounds like there is something in the soap request that Siebel is not able to understand. Is the error being returned in the soap fault?

Capture the request that is working when sent from XML Spy and compare it to the request being sent from IS.


The only difference I see is that the SOAP request from webMethods is adding few extra tags to the xml where as the XMLSpy does not. Attached is the request file for your review.

The request coming out of webMethods IS looks a bit strange. It really should look more like the XMLSpy version. Can you post the WSDL you are using? We will take a look at that.

It looks like the issue is with the IS not having IS_SP1. I have tried the same in one more IS where IS_SP1 was available and its working fine. Also we had asked our customer to provide a SOAP Message binding instead of SOAP RPC. The error with SOAP Message wsdl on IS without IS_SP1 is showing as “SOAPAction ‘<?>’ is of invalid format: SOAPAction should be of the form “rpc/operationName” or “document/operationName”.(SBL-EAI-08006)”.


The SOAPAction http header property is required in SOAP 1.1 but is deprecated in SOAP 1.2. IS will populate SOAPAction if the WSDL specifies it, but does not use it in any way on incoming requests.

Were you using IS 6.5 without SP1 or some other release? (BTW, there will be a SP2 for IS 6.5 in December 2007.)


The IS ver is 6.1

  • Vasu