SAP RFC not giving any output

Hi All,

I have created a B2B outbound MAP using SAP adapter admin console when I run the flow in developer not getting any output.

First I lookup of the SAP Function Module in SAP adapter admin screen, and then create a MAP, provided folder, servicename, package and I saw a service is automatically created in wM developer with the given service name and has a step with serverName, $rfcname hard coded and input/output specified in SAP FM(I followed the steps are mentioned in SAP adapter user’s guide).
But when I am trying to run the flow service in wM developer I am not able to find any output rather I see some $ variables in output… $rfcname, $runtime, $rfctime $encoding (value is ISO-8859-1) & $call (value is false). Although when I test the FM from SAP adapter admin screen I can get the output. I have deleted the DDIC cache and recreated the flow once but still not working.

Can anybody pls help what could be the possible reason?
My SAP adapter version is 4.6 SR1 and IS ver 6.1


got the solution. Need to initialize output variables before the RFC call in wM service.


got the same problem atm. Imported RFC function via Lookup within the web-interface. The service returns some output, but not all.

Could you please describe the way you “initalized” the output?


Solved the problem.

Seems the SAP Adapter 4.6 doesnt support optional structures as return values.

You need to set a blank row to the input structure if you want to have this structure as output or you define the structre as required in SAP.