SAP Integration using 9.7 Trial.

I downloaded the webmethods 9.7 trial and wanted to test the SAP Adaptor.

I see that the ‘SAP Adaptor’ is not shown under the IS Admin->Adaptors. Even when I try to create Adaptor service using designer, It only shows that the JDBC adaptor is available and not the SAP Adaptor. But under the system packages I see that the package WMSAP is loaded.

So, SAP Adaptor is partially loaded and I am not able to connect to SAP using webmethods 9.7 trial. Did anyone use SAP Adaptor using webmethods 9.7 trial?

Thanks in Advance.

Hi Sam ,

Please place the SAP Jco jar files

  1. sapidoc3.jar
  2. sapjco3.jar

in the server classpath and then restart the IS .

1 Like

Thanks Rakesh, It worked after copying all the files sapidoc.* and sapjco3.* to the lib folder worked for me.

I understood that it not only needs .jar files , but also other files ( sapidoc.* and sapjco3.* )

There is a dll file “sapjco3.dll” which you need to register in windows OS.
For unix system placing sapidoc*.jar and sapjco*.jar will suffice.

Usually there is no need to register the dll on Windows.

It should suffice to place it under IntergrationServer/lib.
This is also true for the Unix-variants libsapcjo3.so or libsapcjo3.sl.
Please make sure that these are executable by your application user.

The jars sohould be placed under IntegrationServer/packages/WmSAP/code/jars/static.
This is described in detail in the SAP-Adapters-Installation-Guide.

Please remember to shutdown and restart the IS after placing the files.

Regards,
Holger