SAP BC and SMIME version 3

Hi folks,

We run a SAP Business Connector version 4.6 which has build-in support for S/MIME version 2 - it uses a java library from a company called IAIK for supporting all the cryptographic standards.

Unfortunately the S/MIME version 2 standard becomes rather old and the latest version 3 is being used more widely now …

Has anybody ever considered upgrading the SAP BC server to support this new standard ? Big question is whether this can be done …

The company IAIK has already newer versions of their libraries which support the new version so we were wondering whether the older library can easily be replaced by the new version?

Are there any alternatives available? We are already looking at the free package of ‘Bouncycastle’ but the package might conflict with the existing IAIK …

Do the newer releases of WebMethods integration server support S/MIME version 3 ?

Any ideas or suggestions would be appreciated,

Thanks

Steven