SAP Adapter 6.5 Adapter visibility issue

Hi guys,
I have urgent issue pertaining to SAP Adapter 6.5 on an IS 6.5 (AIX)
I got all the JCOs in the places where they are supposed to be.
My WmSAP package is enabled.

For some reason i still cannot see the SAP Adapter in the admin console.
I know this issue has been discussed in various threads but i cant find a satisfactory answer to my issue.
Any help would be monumentally appreciated !
Scoobydoo !

I Solved it by adding this part of the config block in the file.

#for sap adapter


Sorry I forgot one more thing i …you gotta have these files:

librfccm.o under IntegrationServer_directory\lib under IntegrationServer_directory\lib\

sapjco.jar under IntegrationServer_directory\packages\WmSAP\code\jars\static\

sapidoc.jar under integrationServer_directory\packages\WmSAP\code\jars\static\

sapidocjco.jar under IntegrationServer_directory\packages\WmSAP\code\jars\static\


Is this is all covered in the SAP Adapter installation docs?

Yes are right, I missed out on jar files part.
I figured I’d post the solution here for anyone who might be facing the same issue.

Did you use version 2.1 jco files like the install guide suggested? I can’t find 2.1 adpaters on the SAP site via the marketplace? We used 2.0 and we’re having issues with missing packages under the WmSAP folder and getting IDOC lookups?

I used the latest available JCO v.2.1.8.
Works fine for us.And we did get it from SAP market place.
I suggest you talk to your SAP Dev team regarding the JCO. They should be able to assist you.

What is the error message that you see under the package?
Is it being partially loaded?
Are you not able to see the package?

No it loads ok - what happened was we installed it locally on our laptops (Windows XP) to make sure we worked out any kinks etc., then we installed it on our Unix system. When we browse the SAP services on our laptops we have a whole lot more services under the folder than we do in our Unix environment? It does seem to be up and running but we’re now having major issues with the new SAP IDOC lookup/verification. Can’t seem to find a lot of defined IDOCS on our SAP system?


Could you paste the error if there is one?
Or Its just that you are not able to see all your defined IDOCS?

What fixes to you have for SAP?

Sorry for the delay - I was out of town. Turned out to be a security issue. The new IDOC lookup in teh SAP Adapter uses WE30 in SAP. We did not have access for our WM User for that transaction. Once we got that defined we had no more problems!

Thanks for posting the remedy.
Ill try to Remember this if i ever see an issue similar to yours.

Same problem I was geting in my environment.Above I mentioned my environment as well as my errors.

Plz any body respond on this issue.
i.e very helpfull to me