SAP Adapter 6.5 Access Denied Error

Hello all,

I’m trying the new SAP Adapter.
I followed installation and user guide and I tried to receive a SAP R3 MATMAS IDOC with a notification adapter.

I have the following message in my SM58 transaction :
[SAP.115.9140] Notification error [ISS.0084.9004]

In SAP Adapter > Transaction > TID link [ISS.0084.9004] Access Denied

  • My RFC user defined in Listener doesn’ exist in IS users
  • SAPUSers user has SAP ACL
  • I put no Authorization Service in Listener parameters… => granted by default
  • ACL permissions of my Notification adapter get not changed. (Default for read, write and execute ACL List)

=> As described in user guide (security part) these parameters should grant access properly.

What do you suggest ?
Thanks in advance


have got this resolved? if yes, could you tell me the steps you followed to resolve this. thank you.

Hello all,

I'm getting the same error also when I try to run a Function Module in SAP that triggers one of my IS service.  The only way I managed to make it work is to set  the permissions to Administrator to the SAPUsers.  There must be another way, it seems to me that it's a little bit drastic to set admin on that user.

Thanks for you help…if anybody can hopefully answer us.


You should set the Execute ACL in the service to SAPUsers and it will work fine…