running java service

Hi,
When I am tring to run Java service first time I am getting the error like
couldnot compile
com.wm.app.b2b.server.ServiceException:[ISS.0014.9166] Unable to locate or start compiler.

Can any help me on this…

Welcome to wMUsers. Please search the forums for “unable to locate or start compiler.” I’m sure you’ll find the information you seek. (This topic has been covered once or twice, if I recall correctly.)

Hi,

You can refer the following existing thread. It will be very useful
http://www.wmusers.com/forum/showthread.php?t=948

Thanks!
Arul

Hi Nagesh,

You need to set the JAVA_DIR located in server.bat located in

:\IntegrationServer\bin\Server.bat

SET JAVA_DIR=:\jvm\win142\jre.

before setting stop the IS Server save the changes and restart the IS Server

Reamon,

Could you please confirm is that correct, if we do the above settings?

Thanks in Advance
Gouse.

I can confirm two things:

  1. The information is in the documentation.
  2. The information has been posted on these forums many, many times.

My answer pointed to the documentation to help make readers of this thread more self-sufficient–they become self-sufficient by looking up answers to such basic questions in the docs and the forums. I hope everyone will encourage posters to review the documentation when the answer to their question is clearly covered there.

Thanks Reamon :slight_smile:

Thanks to every body…

Developer. The easiest way to solve this as follows:

  • In Administrator, go to Settings > Extended
  • Choose Show and Hide Keys
  • Locate the entry watt.server.compile, check the box next to it and hit the Save changes button at the bottom of the page
  • Now click Edit Extended Settings
  • Locate the watt.server.compile line and add the full path to your Java compiler (javac executable) in front of the javac command, for example, if you have webMethods installed in D:\wm65 and you want to use the compiler shipped with IS:
    watt.server.compile=D:\wm65\jvm\win142\bin\javac -classpath {0} -d {1} {2}
  • Hit the Save Changes button
  • You can now try saving your Java service again (you may need to add a space or something so that Developer knows it has changed). There is no need to restart IS after this change.

I’m so glad these instructions, which are in the wM Installation Guide, have been posted here yet again! Yippee!

We do have:

  1. SET JAVA_DIR=:\jvm\win142\jre.
  2. watt.server.compile=D:\wm65\jvm\win142\bin\javac -classpath {0} -d {1} {2}

But still we are having this problem!

Hi NageshWM,

I am able to resolve my IS java svcs compilation problem with your instructions to change the extended properties with the javac path.

Thanks.