Role based access for MWS TN set up

Hi there,

I am trying to set up a role based access for Trading Network activities in MWS. I have completed the below set up

  1. Created a new role in MWS.
  2. Created a new user in MWS and added to the role created in step1.
  3. Created a Dataset and assigned the role to it.
  4. Within the dataset, i have selected specific trading partners and document types and given permission to view the content of the transaction.
  5. In IS, i have added the MWS role to “TNAdministrators” “TNMWS Users” ACLs.

When i login with the user which i have created, i am able to see transactions related to all partners and for all the dcoument types. I tried removing the role from “TNAdministrator” ACL in IS, but am not able to view transactions page (Access denied) in MWS.

Am I missing anything here? any help is highly appreciated.


Any way try to add more role one by one like MWS user & Administrator. It should work

Let us know with update

Yes if Administrator doesn’t work then login as ‘sysadmin’ user and configure the role/access for your user.


I don’t have any issues with the “Administrator” user.

When i login with the new user which have restricted permissions, should only view transactions related to partners/ document types added to the dataset. This is not happening.

In systemwide->permission management, Grant the required permissions for the roles

It should wrk for you hopefully. let us know with update

Hi Sai,

I am doing this configuration in wM 7.1.2, i don’t have permissions management page in System- Wide setting. I did granted the required permissions in “B2B Permissions” page.

In the 712 you need to go to the Roles page and click on the particular role (you want to give access) and look for the Members tab and then in the popup search for the new user you have created and assign it to the right and save it.

Then login as new user and browse the B2B pages and see if that works or not.


Thanks RMG for your reply.

I have already did that. My user is part of the role which i have created and also part of “My webMethods Users” role.

Still isn’t working?

Yes, still it is not working.

maybe you should work with data level security settings.

Yes possibly:

Hi there,

For Data Level security,

  1. I have created DataSet and restricted this dataset to specific Trading Partners and Document Types.
  2. Restricted permissions to resubmit/reprocess/view content/edit content etc.

What else i need to configure for data level security? (it is still not working and am struck here)

enable the property in WmMonitor package, not sure if there are any more. try documentation.

Yes please do cross verify the MWS/TN Administrator user guide vs your setup for more information on Role based security…not sure what is esle missing in your env.


I think I have followed the steps mentioned as per the SAG documentation. Is there something to do with ACLs in IS?

Did you restart IS/MWS also?

Yes, i did restart the IS and MWS after I completed the required configurations

If you have followed steps from docu and problem still persists…open up a ticket with SAG support also.

Not sure what else is missing in your config:



It’s been so long all active members are trying to figure out reason of issue and giving out valuable comments

What made you stop opening SAG Ticket? I think you do it also by now