Response is returned as string and not as XML

The output of a webMethods service is in the form of soapData.

wM service response:

<?xml version="1.0"?>

<soap:Envelope xmlns:soap=“”>
<qas:QASearchResult xmlns:qas=“” VerifyLevel=“None”>
<qas:QAPicklist AutoFormatSafe=“true”>
<qas:PicklistEntry FullAddress=“true”>

But when I test the service in SOAP UI, response message is returned in a CDATA section inside Values element and not as XML.

SOAP UI response:

<![CDATA[<?xml version="1.0"?>
<soap:Envelope xmlns:soap=“”>
<qas:QASearchResult xmlns:qas=“” VerifyLevel=“None”>

The response content is treated as string and not parsed as XML.

But I need the ouput message as it is… i.e as soapData and not inside a CDATA section.

Is there anyway to indicate that the response message is a valid xml and it should not be treated as string.
I tried to do string to node,node to doc conversions, but nothing worked.

how are you performing your test on SOAP UI using the WSDL file?

I have not created any WSDL for this.Service consumer would use the webMethods service endpoint(…invoke/ …) and make a HTTP call.
To test this,I have created a test step in SOAP UI with HTTP test request,given the webMethods service end point in ‘request URL’.
I have also added a header to set content Type as ‘text/xml’.

Internally in the webMethods service I have made a call to third party,which is returning the soap response.
And webMethods is expected to pass on the message in the same format to the service consumer.

If i run the service internally ,output is in the form of soapData.
But in soap UI ,response content from webMethods service is coming as a string in CDATA and not as valid SOAP message.

Use the pub.flow:setResponse service in WmPublic and set the response as text\XML at the end of the flow and see if that makes a difference.