remote invoke in scheduled service fails with null pointer e

I have built a webMrthods B2B service that remotely invokes a service on another B2B (Trading Networks) server. When I’m in the developer this services works OK. When I schedule the service it fails with null pointer exceptions. I can not figure out why. I tried to increase max threads for scheduler, max threads for server, global or session scope. All fails. The B2B client is 4.0, the remote server is 4.0.1 This might has something to do with it?
Any suggestion is welcome.

It’s not the different version of the servers.

Maybe you can help me with the Java code?
webMethods is a bit slow in reacting and I need the scheduled remote invoke ‘desparately’


If memory serves me correct, we had the same problem with scheduled flow services. Just upgrade to 4.02, that solved our problem.


We are experiencing the same problem when remote invoking a service from the scheduler.

This is a know issue and this seems to be fixed in Ver 4.6 webMethods version .

But if you dont want to upgrade your server , you can use custom Java code for invoking a service .

Pramod Nair