Regarding JDBC Adapter

Trying using the oracle.jdbc.pool.OracleConnectionPoolDataSource DataSource Class.

Hi Dinesh:

No luck. I tried this even. Any other thoughts from anyone?


DataSource class that you specified “oracle.jdbc.pool.OracleDataSource” should work fine.
Also fill this in the adapter connection settings
networkProtocol :TCP

And also make sure the Oracle DB is up and running.



Iam pretty sure that DB is up and running. I tried using TCP and it did not work even. My error says Prohibited package name: java.sql so I think it is related to some java security issue.

We are using networkProtocol tcp, and have many JDBC connections. We also are running the most recent JDBC 6.0.3 Feature Pack 1.
Insure that

  1. you have the file from your Oracle installation copied to your server at location: /opt/webMethods6/IntegrationServer/lib/jars

  2. You can connect to your Oracle instance with your specified user Xref and password

Restart your server to pick up your and it should connect.



Include the file in to the path which Randy metioned above and bounce the IS.
Actually i got this clue a while back but i was bitt hesitated to convey,since this is a basic step and believed you might have done this.


I have ojdbc14.jar in the lib/jars directory. I will replace it with as suggested by Randy.

Hi Randy and RMG:

Extremely thankful for ur help and suggestions. It works now. But as per the documentation it was mentioned to place the driver jar files in WmJDBCAdapter/code/jars directory. Hence I placed there and also had ojdbc14.jar. When I changed it to it works now. Once again thanks for your time.