Pubschemavalidate issue


In the validate service are you passing in ConformsTo= Schema or DocumentType (fully qualified name),and what all the other params are you passing to that service.


I use the send XML file to do quick test, there is only the validate service in the flow, and take ‘node’ as input, ‘object’ and ‘conformsTo’ of validate is set, ‘object’ is set as input node and ‘conformsTo’ is set to the fullname of the schema document type which is created base on the xsd file. I haven’t set the optional input parameter as I consider they are irrelevant.


I just notice the pieces of schema I provided in first letter is missing some text, and when I tried to resubmit it, it still got missing when I preview my new message, it seems that the cgi function I am currently using to post message get rid of any text inside “” and symbols such as “=”. I’ll try to upload my .xsd and .xml by attach function, hope that works.

phonenumber_test_1.xsd (0.4 k)

phonenumber_test_1.xml (0.2 k)


I loaded your Schema and it just created ELEMENTS/PHONENUMBERS/Anonymous but not COMPLEXTYPES.

And so i parsed the xml document with just passing PhoneNumbers and it parsed fine and when validating against the Schema and i got this Exception

“ [ISS.0062.9024] Integration Server does not support this type of object in validation >>>BasicData:PhoneNumbers=<<<vectors=false complex=true hasBody=true hasChld=true”

So are you getting this same error in the validate service?This is the error you are looking for?


Min Li and RMG,
the difference might arise with you both using different IS versions?

I remember that with v6, the schema validation was more strict.

Min li,
on what version of IS you seeing this behaviour?

  • Saurabh.


you may be right,i am on IS6.x version…and it is behaving as expected…

Let wait and c for Min Li’s response.


Hello, All,

Thank you for your response. The IS version I am with is IS6.0.1.

When I validate the xml document of phone number against the schema, I don’t have any service exception as RMG described. What I am complaining about is, when xml file with an empty phonenumber element is validated against schema, I am expecting isValid return false and errors be returned. (Which is the case with XMLSPY), because in the schema, it is defined at least one of the child element should appear for telephone number. However, with pub.schema.validate service, it always return isValid as true.

I can only create the schema in WM Developer by loading xsd file and it always create ELEMENTS/PHONENUMBERS/Anonymous but not COMPLEXTYPES even I define so in xsd file. I would like your advice if you know how to create the COMPLEXTYPES in schema and if that is the key of this problem.



Still i am getting the same exception and here with attaching the complex xsd file.please check this one and test the validate service.


phonenumber_test_complex.xsd (0.3 k)


The reason that you get the exception is probably that, the xsd file you are using does not define the element. If you use this one, you should not get the exception.

phonenumber_test_complex-36773.xsd (0.4 k)


I loaded the schema but Still getting the same exception which i mentioned above in the validate service.