Publishing API fails with error "Unable to publish API '***'" error

What product/components do you use and which version/fix level are you on?

WebMethods API Gateway
Version: 10.11.0.9.234

Is your question related to the free trail, or to a production (customer) instance?

Production Instance

What are you trying to achieve? Please describe in detail.

Publishing REST based API. The API definition is created using OpenAPI Specification 3.* and it has been validated using swagger-cli.

Do you get any error messages? Please provide a full error message screenshot and log file.

Publishing API fails with error message “Unable to publish API ‘xSys’”.

2022-08-18 10:21:28 GMT [YAI.0007.0021E] (tid=1591) Publish API. Unable to publish API: ‘xSys’ to portal. PortalResponse status : 500, PortalResponse Message : {“message”:“Error in publishing API. Error Message: API is getting published from another thread”}.
2022-08-18 10:21:28 GMT [YAI.0007.0015E] (tid=1591) Unable to publish API ‘xSys’.
2022-08-18 10:21:28 GMT [YAI.0001.9999E] (tid=1591) [apigw_test][eimreytwbms02][APIGW:19d2ade0-a8fe-4a0a-a1d0-c5a0dae26e76:1591:009f40c798f04f87ba776589d9e00c8a] Exception : Unable to publish API ‘xSys’. com.softwareag.apigateway.portalinteractions.exceptions.ApiGatewayPublishException: Unable to publish API ‘xSys’.

Note: Earlier when i faced this problem i used force unpublish API and republish it again, but this no longer works.

Additional details:

  • REST API usually takes in excess of 3-4 mins before it fails.

Hi Manjunath,
Is this happening with a specific API? If all API publish is failing then it is better to raise a Service Incident with support for further analysis. Please also check the hanging threads in API Gateway which may be blocking publish.

Regards.