'pub.task.taskclient:queueTask"' com.wm.app.b2b.server.ISRuntimeException: SOAPException( Server.userException: [POP.001.0002] A "java.lang.NullPointerException" occurred with the Message "null" )

Hi All,

I have created BPM process with Task. When i publish document the user task returning following error.
Process Error:
com.wm.app.prt.ProcessException: [PRT.0101.9125] Service MyPOCProjectBPM.myPOCDemo.myPOCDemo_1.Default:UserTask_InputMapService failed. com.wm.util.BasisException: SOAPException( Server.userException: [POP.001.0002] A “java.lang.NullPointerException” occurred with the Message “null” ) at com.wm.util.BasisRuntimeException.(BasisRuntimeException.java:86) at com.wm.app.b2b.server.ISRuntimeException.(ISRuntimeException.java:194) at impl.TaskEngineMWSImpl.queueTask(TaskEngineMWSImpl.java:130) at pub.task.taskclient.queueTask(taskclient.java:80) at java.base/jdk.internal.reflect.NativeMethodAccessorImpl.invoke0(Native Method).

WmTaskClient: when i run below service by using task id and returning following error message “SOAPException( Server.userException: [POP.017.0017] Task ID is not valid E9878CDC-71AE-7B9E-9394-94D31507FEF0 )”.

WmTaskEngine: When i tried to open WmTaskEngine Home page showing empty.

Also. I have enabled the debug log for this service "MyPOCProjectBPM.myPOCDemo.myPOCDemo_1.Default:UserTask_InputMapService " in the pipeline the inputs are present. After passing inputs to “pub.task.taskclient:queueTask” service returning “SOAPException( Server.userException: [POP.001.0002] A “java.lang.NullPointerException” occurred with the Message “null” )”. But when we pass default Task id, no issues.

Kindly advise,


Hi Abdullah,

please provide your wM version as well as some more informations about your task implementation.
I am not sure if the WmTaskEngine package is intended to have a home page as I have never worked with a version which provided a WmTaskEngine package running on IS. We had only a version with TaskEngine running on MWS.

Were the process and task deployed properly to the respective servers?

Is there anything in the logs when attempting to load the homepage of the WmTaskEngine package?


Hi Holger,

Thank you for your reply.

wM Version: 10.15


User Task:

Process and task deployed to servers.

WmTaskEngine: No logs found.



Issue is resolved after updating new “jsass-5.11.0.jar” due to this the project not publishing to servers. Thanks for support.


Old Jar: io.bit3.jsass_5.4.3.jar
New jar: jsass-5.11.0.jar


Hi Abdullah,

in this case you should check if you are allowed to download Fixes from Empower and apply them to your installations (Server and Designer).
If you are not sure please log a support ticket to get this clarified.


Hi Holger,

Sure and thank you for your support.


Hello Abdullah,

I am also facing same issue. I have tried placing new version of the jar file you mentioned, and restarted IS, MWS, and redeployed Process Model and Task, but I am still getting the same error.

zzz_DemoProject.zzz_DemoProcess1.zzz_DemoProcess1_1.Default:Demo_Task_InputMapService failed. com.wm.util.BasisException: SOAPException( Server.userException: [POP.001.0002] A “java.lang.NullPointerException” occurred with the Message “null” )

Is there any other steps that I need to perform to get rid of this error ?
Is there any fix available for this already ?

Hello Hitesh,

Can you please apply the latest fixes by using the update manager?



I was earlier using few simple fields as business data in task and this was resulting in null pointer exception.
Later I tried using a dedicated document type as business data for Task and it worked smooth.

Maybe it is a good practice to use a dedicated document type instead of individual fields as Task inputs.

Thank you for the responses.