pub.flatFile:convertToString not creating 'String'

I faced an issue where ‘pub.flatFile:convertToString’ is not generating ‘String’ as an output. I have verified the flat file schema, dictionary and the flat file document, everything looks fine. But, the string wasn’t getting generated. Have tried installing recent fixes for flat file as well. Nothing did worked, have struggled for almost a day without understanding what is the root cause.
Finally, I tried changing the case of the ‘record defintions’ in flat file dictionary to match with the input document of the IDATA , regenrated the flatfile document and then used the newly generated flat file document as a reference to map the IDATA document, invoked convertToString service with the newly mapped flat file document as an input, and it worked. The flat file string did generated without any issues.

1 Like

Hi @sasikala_Manyam1 ,
Thanks for your post and glad to know that you are no longer facing the issue. However, on the public service, can you please specify which version are you using? At what fix level? Any error message that you got? What is the output of the service?
This would help us find a suitable solution

This topic was automatically closed 180 days after the last reply. New replies are no longer allowed.