Pub.client:http is taking 2min+ to just invoke or anyother url

Hi All

At present we are on 10.3 on a vm and since few days we are observing that when URL invokes done using pub.client:http is taking >2minutes to make a call and get the response.


we raised a ticket with SAG and they said we cannot provide any support/patches/fixes as 10.3 is out of support .

Did anyone face this kind of issue?

Attached the image for reference. It worked correctly before if i do that from my local and connect to the test server and do the tests it is taking milli seconds.

You need to purchase extended support for version 10.3 or upgrade your environment, otherwise they won’t help you at all.

To isolate the problem, did you try invoking the same service from different environments and from a simple java application?

Without extra information I would check if the DB is doing Ok and it is not heavily bloated and also there is enough disk space. If there is a huge amount of data waiting to be archived/purged, doing that may fix your issue. If you are not using an RDBMS to save your pipeline we need more information. Try increasing your log level and getting the logs from http client service. If my memory is correct, they should be written into wrapper.log not to server log, but you need to increase log level first to see those logs. Don’t forget to decrease loglevel later. Also installing the latest fixes can also help. You can try that first.

Maybe it is related to the proxy settings of IS or the network outside of IS

When this service execution is in progress, please take multiple thread dumps. Thread dumps may provide some insight on where exactly pub.client:http is waiting on.


@parre.abhijith Its should be something to do with your VM / Network point if the behavior’s are observed all of sudden. Also try to compare the hop involved between you local and problematics. if your patterns is something seen to all the endpoints which you are calling from your server then it should be something you have to see any changes to your infra is causing this issue.

Note : Does your global timeout values is not kicked in ? since you mentioned you could see response around 2 mins. Ideally timeout values should be in placed when you are making any external call as best practices to safe guard your resource

1 Like

Hi @parre.abhijith ,
The rest of the responses do a great job in accurately addressing possibilities within and outside the Integration Server :+1:
I would like to add - Have you tried calling the same URL with a different client such as a browser? this will help in narrowing down where the problem is.


This topic was automatically closed 180 days after the last reply. New replies are no longer allowed.