PSUtilities.misc:makeSystemCall java Service is not running

Hi All,

I want to call windows(cmd) command in webMethods developer so that i am using makeSystemCall service from PSUtilities package but whenever i am trying to run this service i am getting below error:

Could not run ‘makeSystemCall’.


Can anyone please help me on this it’s really very urgent.

webMethods version :- 8.0
IntegrationServer :- Solaris 10

command :- cmd /c ping ‘some address’ -t

I have disable the config entry code in java service so i hope no need to edit config file.

Please HELP!!!

Warm Regards,
Yogesh Bhandari

Try using executeOSCommand which is available in WmPublic…

But executeOSCommand is used to execute shell script or OS(IntegraionServer) command…rit??

It can run anything. It is simply creating an OS shell and running whatever command-line you pass.

But it is also throwing below error when i am passing cmd /c ping ‘server’ -t as command

Could not run ‘executeOSCommand’ Cannot run program “executeOSCommand”: error=2, No such file or directory

Drop the cmd /c part from the command. That’s for Windows. You said your IS is running on Solaris. Just do ping host

If you use the -t options you’ll need to specify a ttl.

Yes IS is running on Solaris…but my main concern is to override the IS layer and invoke cmd command from flow service…Can you assist??

You cannot “override” the “IS layer.” All services run on IS, nowhere else. You cannot invoke “cmd” on Solaris–it doesn’t exist.

It is quite common for those new to Developer/IS to believe that services run in Developer run locally. They do not. They run on IS. Always. There is no way to change that.

Thanks Reamon…So it is not possible to call cmd Command from Developer…:frowning:

No. Developer cannot be used to call anything at all. It doesn’t run the services. IS does.

kkk…Thanks for your help…:slight_smile:

create a java service to call the dos command and you should be ok
Sorry for the 10 years diference…

He doesn’t need to create a Java service. There is already one available. Developer does not execute services. IS does. So only commands & programs on the IS host can be executed using the services identified in this thread.

Yes, Reamon is right…i tried to write java service in developer but getting same error message…:frowning: