[PRT.0101.9195] Could not enable model

Im trying to deploy BPMS process model to IS using WmDeployer and deploy is succesfull (no error in deploy report) but process is disabled for execution in WmPRT package. In <process_name>.process file i have:

<qualityOfService expressPipeline="true" minLogLevel="5"
    optimizeLocally="true" volatileTracking="false" volatileTransition="true"/>
  <edaIntrinsics processEvent="false" stepEvent="false"/>
  <easeOfOperations enableProcessForTrackingInTarget="true" enableProcessInTarget="true"/>

Process is visible in MWS as enabled for execution and analysys but create process attempts (simple document publishing) fails with error:

[PRT.0101.9264] Cannot create new instance of model version 1, it is not enabled

I have tried enable process manually using wm.prt.model:enableProcessForExecution service but it fails to with error:

[PRT.0101.9195] Could not enable model “CaBusinessProcessBrokeredProductBlik/T6Transaction” version “1” for execution

Any suggestions?

Are you sure you’ve deployed all the necessary assets (generated package etc)? Go to the home page of the WmPRT package and display dashboard there. Are all the models displayed as enabled?


I am also facing issue where deployed process model is not gettin enabled in WmPRT’s Process Model section.
Though deployment was smooth and even the business model in MWS was enabled for execution, we are not able to publish documents to the Broker.

Any pointers on the issue will be helpful.


Hi Mayank,

can you describe your issue in detail please?

What exactly happens when you are trying to publish documents to the broker.


In my case problem reason was diferent process id’s in process model and process deployed on process engine server (diferent full names in visible in WmPRT and WMS).

For example: in SAG Designer solution I had path /Processes//
and process Id after deploy on process engine IS in that case should be // (visible in WmPRT)

But I’ve screw up deploement map for WmDeployer and after deploy in MWS (option: “business processes”) i had /BPM/

Hi Holger,

Before publishing the document we want to enable the process model on the WmPRT/Process Models section.

  1. There are couple of builds deployed - Build A is BPM related containing IS packages
  2. Build B is for process model

I deployed Build A and B without any issues.
Then from MWS I enabled the process model for execution
But when i check the same process model in WmPRT its present but not enabled.

I have tried deleting the IS pacakges, Process Model from DB(using process key/ModelID) and redeploying all of the assets again but in vain.

wM v8.2


Hi Mayank,

can you try the following:
Prepare a build only containing IS Packages, but not the Package with the generated model services and second on containing the BPM Model and the generated package for the model (via resolve depencies). Select the custom packages as “Exists”.

First deploy the packages only build and then deploy the BPM build.

This scenario works us for the last years.

In the Process Development we have all the steps defined to just invoke the corresponding services in the custom package.


Hi Holger,

We dont have the feasibility of creating build, we get the build file from a different vendor.
We simply import/deploy the build or in case of issues ask for a fresh build for deployment.

But we had tried deployment for a different BPO build and we were able to enable the process in WmPRT successfully.

Initially i noticed that the builds we were receiving from Build team was on wM v7.1 and we were deploying it on v8.2 so i suspected deployer compatibility issue.
But i am not sure if thats the issue anymore as we have deployed one of the builds successfully from v7.1

I assume the initial issue was with the build and i have asked for a fresh build to give it a try.
Fingers Crossed!


Hi Mayank,

projects build from 7.1 cannot be deployed to 8.2 by default.
Deployer should block this.
They need to be migrated before.

The best way is to keep versions of dev, qa and prod systems in sync.