Process instances are missing in database

Hello,

We have a problem to run a business process in AIX environment.
It has been developed and tested in windows platform and tests were fine. The problem is when we’d like to test the business process in AIX platform, no instance is created in database.

To deploy the business process in AIX plateform, we used Deployer. 2 builds were created with no problem: one for the process model and the other one for the process flow services. The 2 builds were successfully deployed. Then, we enabled successfully the process in MyWMS.

In the AIX environment, when we run the first process steps:

  • In the broker, it seems that the step is running well. Indeed, we are able to see the flow services execution, IS documents types and the PRT related to the step;
    However:
  • no process instance is inserted in process logging database. Consequently, no process instance is shown in MyWMS business monitoring screen;
  • there’s no error messages neither in IS logs(Although the log level was risen to 10) nor in repoV3 logs(stored in flat file mode).

In AIX, we removed jaxrpc.jar file from wmDeployer/code/jar/static, then restarted the IS and re-deployed the model build
(according to this issue: http://wmusers.com/forum/showthread.php?t=10040&highlight=remove+wmdeployer) but it didn’t resolve the problem.

Any ideas?

About AIX environment:

  • IS 6.5 (IS_6-5_SP1)
  • JVM: 1.4.2 (48.0)
  • AIX 5.3
  • MyWMS 6.5.2
  • WmPRT 6.5.1
  • WmMonitor 6.5.1 SP2

About Windows environment:

  • IS 6.5 (IS_6-5_SP1)
  • JVM: 1.4.2_07 (48.0)
  • Windows 2003
  • MyWMS 6.5.2
  • WmPRT 6.5.1
  • WmMonitor 6.5.1 SP2

This problem may occur if the audit system in the Integration Server is configured to use the file system rather than the database.

Check the extended settings of the Integration Server and make sure sure that the audit store is configured to use a database.

watt.server.auditstore=database

-Rob

When I added this extended setting, I found this error is IS logs:

2007-09-26 23:59:51 BST [ISS.0095.0003C] AuditLogManager Runtime Exception: java.sql.SQLException:[wm-cjdbc34-0042][Oracle JDBC Driver][Oracle]ORA-01654: unable to extend index WMISCOREAUDIT.IDX_SESS_SVRID by 1024 in tablespace USERS
processing log entry >>>BasicData:RootContextID=3031b8806c8411dc8b63fc2a037c5e7f,AuditTimestamp=1190847591432,ContextID=3031b8806c8411dc8b63fc2a037c5e7f,AuditSchemaName=wMSession,AuditSchemaVersion=1,ServerID=tmsaint:5555,SessionID=23740wX0qlpnWdsFZkoTuukVVk3dOX8-555550,SessionState=2,UserID=Administrator,SessionName=system,Rpcs=0,Age=30<. 2007-09-26="" 23:59:52="" BST="" [ISS.0095.0004C]="" AuditLogManager="" Runtime="" Rejected="" entry="">>>BasicData:RootContextID=302d24a06c8411dc8b60fc2a037c5e7f,AuditTimestamp=1190847591402,ContextID=302d24a06c8411dc8b60fc2a037c5e7f,AuditSchemaName=wMSession,AuditSchemaVersion=1,ServerID=tmsaint:5555,SessionID=23740wX0qlpnWdsFZkoTuukVVk3dOX8-555550,SessionState=1,UserID=Administrator,SessionName=system,Rpcs=0,Age=0,$$$AUDITPROCESS={MemData:DefaultJDBCConfig_1=4},ERRORINFO=java.sql.SQLException: [wm-cjdbc34-0042][Oracle JDBC Driver][Oracle]ORA-01654: unable to extend index WMISCOREAUDIT.IDX_SESS_SVRID by 1024 in tablespace USERS

Should I re-run DB scripts?</.>

the extended setting solved the problem. Besides, cleaning database solved the oracle problem. Thanks!