Problems invoking a webservice through a reverse gateway

We do have a brand new ESB environment including two IS - one internal (INTERNAL_IS) and one in the DMZ (EXTERNAL_IS). As I can see, the connection from the INTERNAL_IS to the EXTERNAL_IS in the DMZ works fine (no Errors/Alarms in the Logs).

Unfortunately, I do not get any response when I try to invoke a service through the IS in the DMZ using the Internet Explorer (nothing happens). I tried to invoke a simple service (without any input parameters) which is includes in the Package WMArt:

works:
http://INTERNAL_IS:1234/invoke/pub.art/listRegisteredAdapters

does not work:
http://EXTERNAL_IS:5678/invoke/pub.art/listRegisteredAdapters

Any ideas?

Marcus,

What is the IS version 822?

Please make sure all the external/registration internal ports are enabled in a step manner…first enabled RG server ports and then Internal ports and if required restart both the server after the configuration

Did you try enable more logging (trace) on both Internal and RG server part of troubleshooting?

Check this thread for more info:

http://tech.forums.softwareag.com/techjforum/posts/list/25541.page

HTH,
RMG

How can I enable a more detailed logging for that?

Thru the IS Admin page

This is for IS712
Settings > Logging -->

Loggers
Facility Logging Level
Default Info
Integration Server –


This is for IS822

Settings > Logging > click on Server Logger -->

Server Logger Configuration
Facility Logging Level
Default Info
Integration Server

View Server Logger Details

Pl make sure you check the link I pasted in my previous comment for the codes you need to enable mainly.

HTH,
RMG

I checked that link below already. This does, unfortunately, not address my problem.

I increased the logging to “Trace” and tried to invoke the service again. I cannot see any entry in the log that indicates an incoming service request or incoming call at all. THe Windows Firewall is turned off and I try to invoke that service in an IE on the external IS. So, there is no network issue between the internet explorer and integration server.

Any ideas? Which entry usually appears in the log?

What logging codes have you enabled on both servers…can you list here?

I assume you checked server.log only right?

Also I would say open a ticket with SAG support as well.

HTH,
RMG

I enabled Tracing for Server Logging/Integration Server/all…