problem with saving UTF-8

I saved initial document in UTF-8 into Tamino using java API.
The document contains Russian and German letters. When I view the document thought Tamino Interactive Interface only Russian letters are displayed correctly. If I save the same document into Tamino using Tamino Interactive Interface and then view it in a such way everything is ok: Russian letters are Russian, German letters are German. What’s the problem? Using java API? How can I avoid it?

Do you know what version of the API/Tamino you are using? I have tests for the API that use German/Korean/Japanese that work for the latest API version [the one that ships with Tamino version 3]. Do you have some sample code/data?

I also tried to load a document that contained russian and german characters. It worked for both and

Plus it is very strange that only german characters were corrupted. If the initial document had been in UTF-8 and encodings had been accidentally mixed up (for instance with Windows-1251), russian characters must have been transformed as well.