Problem while connecting thru workflow client

Hi,
when i am trying to connect to workflow server using workflow client, i am getting error like"server may not be active.waiting to refresh readme.txt from localhost".
i have tried different options like changing diff. ports, localhost name back to mechine name… but still i am getting same error.

the server is always up and running.and i did conigured the workflow .

Any help is Apreciated.

Thanks,
Rao.

Rao, make sure your configuration information for your Workflow server
(host, port, registry port) matches your Workflow “Host Name” settings.
The Workflow server config information can be configured by running:
<webmethods>\WorkflowServer\bin\configure.bat

The Workflow client host settings can be set by starting the Workflow client:
<webmethods>\WorkflowClient\bin\clientmgr.bat
…select the menu option “Host Name”, then click “Options”.

I have seen problems starting the client if the host name (including the case) does not match the host name of the server settings. Remember that the host name information you enter is used to do a lookup in the RMI registry, so case is important.
One other thing to check is that your database services are active.

Good luck!

Wayne

If you are running on windows xp, you may need to reset your ports. My box runs the workflow stuff on 9001/9010, rather than 5001/5010.

Rerun the configuration tool as well just in case. This fixed my problem. Barring this, if workflow is NOT on the same box, perhaps you have a network permission problem?

When workflow client first starts up and it finds the server, it downloads jar files and then asks you to restart the workflow client. Since this has not happened, either you have a misconfiguration of the client, the server is not setup, or you cannot connect to the server for some other reason.

HTH,

Ray

Hi Ray,

I gone through this last step “…restart the workflow client” but it still shows the “…waiting to refresh…” message.
Could it be some kind of network permission problem or anything else?
I already ran the Workflow configurator.

TIA,
Maldonado

Did you run the configurator?

Ray

Hi Ray,

Yes I did!
Actually, after running the configurator the workflow client asked to be restarted e showed the “…waiting to refresh…” message.

Maldonado

I did make some assumptions, but here’s a small checklist:

  1. Make sure that WORKFLOW IS NOT RUNNING.
  2. Rerun the configuration tool for workflow.
  3. Just in case, restart your broker. No broker, no workflow.
  4. Restart Workflow server.
  5. Try to login. Should give you a little box that says update completed click ok to restart. If you don’t see this, you are not connecting to the workflow server.

Ray

Hi buddies,

when i am trying to see the workflow datas in a webpage,i am getting the following error (error : 200 : OK) when i click on the login button after entering my username,pwd,project name etc.

Just 200 : OK

What cld be the reason for the above .Anyone !

Thanks

bluesea

Hi All,
When i am starting my workFlow client I am getting an error Message like “Unable To Refresh Jars From Server. Please retry Later”. Can anybody please help me out. This is urgent. I had rum my workFlow configurator and my broker is also fine. I am working on 6.0.1 version.

Thanks,
Pradeep.

HI All,
I have solved my problem. Using localhost was giving me these exceptions. Instead using the host name i could connect to the workflow server.
Thanks,
Pradeep.

I am seeing a 200 OK error while connecting to HTML client. Nothing else shows. Tried refreshing the packages and Broker Document types but still gives the error.

Questions:

  1. What version of Workflow are you using ?

  2. Are you using the (Tomcat) servlet engine included with the Integration server ? For example:
    http://<is_host>:<is_port>/web/WmWFServlet/wfservlet

  3. If you are using an external servlet engine did you deploy the workflow.war file ?

The more information you provide the easier it will be to figure out your problem.

Regards,
Wayne

Milind,

The pattern I’ve seen with this is that it usually occurs when using the IS-hosted servlet engine. It’s also extremely difficult to troubleshoot, as a direct cause isn’t known. In most cases, the simplest (and best) solution was to use an external servlet engine, which is better anyway for scalability and ease in troubleshooting.

Tate, no offense but the pattern I see for many problems reported in this forum is: user error Not that this is what is causing Milind’s problem…
Many people don’t follow the wM install/setup instructions properly and then come to the forum and say “my webMethods component is not working properly. help me. blah, blah, blah.”.

I agree with you on the point about using a separate/external servlet engine for scalability/mgmt purposes. This would be ideal but I wouldn’t necessarily discourage smaller shops from using the embedded servlet engine especially if they don’t have a lot of web server admin-type support people.

Anyway, we are both assuming that Milind is using the embedded servlet engine. If he (?) she (?) is then it would be nice if we could find out the root cause of the problem.
Personally I find it hard to sleep knowing there is a problem like this that is unsolved

Regards,

Wayne

Wayne,

You are very correct here, especially with the complex setup and usage of Workflow, and I was making several more tacit assumptions. First things first. The Advanced Troubleshooting Guide in Advantage has a section on troubleshooting Workflow (I wrote it), and while it isn’t exhaustive, the techniques there can solve many of setup problems users encounter. BTW, that was written when 6.0.1 was current. As Mark mentioned above, running the configurator while the server isn’t running is an EXCELLENT test because it will verify the connections to the broker and the DB. Again, with 6.0.1 and older (maybe newer), the installer will attempt to start workflow as a service in Windows. However, since the config isn’t right, only a few javaw processes will start. If possible, it’s good to make sure there are no javaw processes running when you start the Workflow Config.

Specifically, with the HTML inbox, assuming the login screen shows up, here are a few other things to check:
–username and password are correct
–project name is supplied
–server is supplied as <server>:<port>
–Workflow.war file is EXACTLY the same version as the workflow server (including fix levels)

The tough 200/OK occurs when the user gets a valid login screen and then, upon submitting the login info, gets the 200/OK. Assuming everything in the advanced troubleshooting guide and the above have been checked, then I’d look into using Tomcat or something similar.

I haven’t used it in 6.1 or later, but in 6.0.1 and prior versions, the embedded engine would swallow most of the useful debug messages–making troubleshooting difficult. Please let me know if this has changed since then. For a small shop with a low-load system where the built in client works, it is fine.

Hi All,

I was finally able to resolve the 200 OK error. Just had to reload the WmTomcat package from Administrator.

Thank you all for your help

Hi friends,

I am now able to login to my inbox but I dont see the tasks which are supposed to be there. I tried rerunning the configurator. Also checked the priveleges in WF Users. There are also no tasks when I view it through WF Monitor. The WmMonitor displys that Manual Intervention has started.

We are using thin browser based client.

Workflow 6.1 sp 1
Broker 6.1
IS 6.1

Thanks

Hi All,

I am having the same 200 OK error. I have reloaded the WmTomcat package from Administrator but my error is not resolved.

Can someone propose any other solution?