Problem running IS as a service

I am facing problem running the Integration server as a service on a Windows 2000 server.
I have tried the following things, but it is still not working. Not sure if there is any problem with the installation.

If IS does not run as a windows service, follow the procedure below:

  1. Uninstall windows service by running
    \support\win32\installSvc unreg

  2. Verify that the service disappears from the services menu

  3. Install windows service by running

  4. Verify that the service appears in the services menu.

  5. If still cannot run as a win service, uninstall the win service by
    following steps 1-2 above and proceed with steps 6-7.

  6. alter JAVA_RUN parameter in server.bat file in the following way (Xrs
    suppresses OS signals):

  7. do steps 3-4 above.

When I log off the server, the IS service stops running and I cannot access that machine using http:\server_name:5555 from my local PC. Any suggestions would be greatly appreciated.


We’ve faced a similar issue… the reason that you are not able to use webMethods is because the service is running under the ID you log on under. When you log off of the box, all the services associated with your ID are killed.

Try having the service run under a system ID.

I uninstalled IS after taking a backup and then re-installed it again. This time the service ran properly.