Problem "Publish" from Centrasite after Activation of Life-Cycle Model "Service Lifecycle"

Good morning,
I have a problem with the fase of pubblication of Virtual Service from Centrasite to Mediator.
I tried to publish the virtual Service created.
The publish on the Mediator works correctly.

After I had to active the Life-Cycle Model “Service Lifecycle” for others reasons.
I activated only the Life-Cycle “Service Lifecycle”. I have done only this action.

After this activation is not possible execute the publish of the Virtual Service.
The button Publish there isn’t anymore after the activation of “Service Lifecycle”.
If I try to create a new Virtual Service and I execute the publish, I have this error:

“Explanation: Could not publish the specified asset ServiceOne to the target, possibly because the specified asset is under the control of a lifecycle model (LCM), and is in a non-deployable state.
Action: Make sure you switch the asset to an active, ready-to-deploy state, before trying to publish asset to the target.”

Do you have any suggestion to resolve this problem?
Thanks in advance.

  1.   There would be a design time policy to enable / disable deployments based on the life cycle state of an asset, please check the policy state, Change Deployment Status Policy  is the name of the policy action.
  2.   If the desired mediator target is not seen in the publish list then to which target are you trying to deploy / publish?

Please refer the product documentation about creation of the policies and mentioned above action.

Hi, Thank you for the response.
I don’t finf the correct policy to enable / disable.
I don’t find “Deployment Status Policy”.
Could you explain better how can I find this policy or action?

Please follow the steps to create the Policy.

1: Select the Object Types as Service and choose “Post-State Change” Event

2: After click on Next ?Select Change Deployment Status Action

3: Configure the Change Deployment Status as True

  1. Select the life cycle state in which the you desired the asset to be published / or ready to be published in the states tab.

  2. Activate the policy.

  3. Now when the life cycle state of the virtual service asset is moved to that state then the publish icon will be seen.

I click “Add Policy.”
The first step is ok.
In the second step, after that i click next, I don’t have “Change Deployment Status”.

I have the list of states: proposed, in design, in developement, implemented, in test, tested, in production,
under manteinance, deprecated, retired, rejected.

It’s normal?

Hi Saverio,

Seshasai had given all the steps and explained in detailed manner.

What is the show stopper issue ? Can you share the screen shots

Thanks & regards,

Hi SeshaSai,

Can you please clarify the below concern .

Is there any specific order that we need to fellow while creating an artifacts on CentraSite ?

Why because , the service are created which are virtualized and published it to Mediator from the CentraSite ,Later If you create the Life Cycle Model for those services and it does not displaying the Publish icon .

I noticed the issue ? Please correct me If I am wrong

Thanks & Regards,

Hello Jeevan Kiran,

Yes you are correct, After creating the virtual service(s) if you have enabled the life cycle state then the virtual services may not be in the desired state and the publish /unpublish actiojs will not be visible, So you have to create the above mentioned design time policy and add the appropriate /desired life cycle state for the asset to be able tp publish or unpublish it.

Once the life cycle state is enabled, all the assets would be in the initial state of the model.