Problem inserting the payload in Tamino

Hello:

I want to insert my payload inTamino. I’ve created a Schema that matches with the payload. I can connect and perform a query without problems, but trying to insert a new document, this error occurs:

[color=“red”]

Exception: “com.softwareag.xbridge.exceptions.XException: TaminoSingleAccessor: Internal error: Message object does not have a connections container.”

[/color]

The “xdb.tamino.connection-name” property is set with the same value in the “SagTaminoConnection” component and the “SagTaminoSingleAccessor” component.

Any ideas? Thanks.

Hi,

Can you tell us a little about your environment. What version of Tamino isinstalled? Is the tamino java api installed with tamino?

If you could, please post the sequence you are using as well.

Thanks,

Matthew :slight_smile:

Thanks 4 replying:

I’m using Mediator Version 7.4.1.1. , on Windows 2000.
The Java Tamino API is installed. The Tamino connection works fine, as the query. Only the insertion fails.
The payload fits with the “Trazas” schema. I’ve tried to insert the payload with the Tamino Interactive Interface (copy & paste), with success.

The sequence I use is:



<?xml version="1.0" encoding="UTF-8"?>
<sequence version="4.0" xbd.zid="N400001">
    <block xbd.zid="N400002">
        <!--{Name: Conexion};{Notes: }-->
        <step component="SagTaminoConnection" xbd.tamino.action="start-session" xbd.tamino.connection-name="MediatorTrace" xbd.tamino.connection.action="start-session" xbd.tamino.connection.connection-name="MediatorTrace" xbd.tamino.connection.database="DBMediatorTrace" xbd.tamino.connection.server-url="http://localhost/tamino" xbd.tamino.connection.transaction-mode="local" xbd.tamino.database="DBMediatorTrace" xbd.tamino.isolation-degree="stableDocument" xbd.tamino.lockmode="unprotected" xbd.tamino.server-url="http://localhost/tamino" xbd.zid="N400004"/>
        <step component="SagTaminoQuery" xbd.tamino.accessor="XML" xbd.tamino.collection="Trazas" xbd.tamino.connection-name="MediatorTrace" xbd.tamino.xql-text="Traza" xbd.zid="N400030"/> 
        <step component="SagPayloadSetter" xbd.payloadSetter.inputURL="http://localhost:8080/slide/users/me/repos/pruebasConexion/TrazaVacia.xml" xbd.zid="N400022"/>
        <!--{Name: set};{Notes: }-->
        <set target="/Traza/msgIN" value="Message IN" xbd.zid="N400024"/>
        <!--{Name: set};{Notes: }-->
        <set target="/Traza/msgOUT" value="Message OUT" xbd.zid="N400025"/>
        <!--{Name: set};{Notes: }-->
        <set target="/Traza/timestamp" value="{'$xbd.factory.arrival'}" xbd.zid="N400027"/>
        <!--{Name: set};{Notes: }-->
        <set target="/Traza/client" value="{'$xbd.portal.client.address'}" xbd.zid="N400029"/>
        <step component="SagTaminoSingleAccessor" xbd.tamino.accessor="stream" xbd.tamino.action="insert" xbd.tamino.collection="Trazas" xbd.tamino.connection-name="MediatorTrace" xbd.tamino.payload-update="true" xbd.zid="N400026"/>
    </block>
</sequence>

The “TrazaVacia” xml is a simple template:


<?xml version="1.0" encoding="windows-1251"?>
<Traza>
	<timestamp/>
	<client/>
	<msgIN/>
	<msgOUT/>
</Traza>

I thing all is right, but …

I think the properties for your connection are a little messed up. The properties in your connection step:

xbd.tamino.connection.connection-name=“MediatorTrace”
xbd.tamino.connection.database=“DBMediatorTrace”
xbd.tamino.connection.server-url=“http://localhost/tamino
xbd.tamino.connection.transaction-mode=“local”

are invalid. The properties:

xbd.tamino.action=“start-session”
xbd.tamino.connection-name=“MediatorTrace”
xbd.tamino.database=“DBMediatorTrace”
xbd.tamino.isolation-degree=“stableDocument”
xbd.tamino.lockmode=“unprotected”
xbd.tamino.server-url=“http://localhost/tamino

are correct. This means you have an auto-commit transaction-mode since this is the default. I am not sure if this is your problem, but I would suggest you correct the sequence and retry.

Let me know how it goes.

Thanks Matthew:

I’ve already deleted the invalid properties, as you said -> same error.

I’ve changed the “transaction-mode” property to “local” -> same error.

I’ve deleted the “isolation-degree” and “lock-mode” properties -> same error.


“com.softwareag.xbridge.exceptions.XException: TaminoSingleAccessor: Internal error: Message object does not have a connections container.”

…more ideas? Thankz in advanz. :wink:

Charlie.

I haven’t been able to reproduce this on my system. What version of Tamino are you using?

There is one small issue in the sequence you designed I think I should let you in on. It is most likely not an issue for your sequence but could make problems for you when your application becomes more complex. The XML accessor, when used in a TaminoQuery will return x documents but Mediator will only process the first. To access all documents you have to either use the stream accessor or you need to place the same query in a while loop and itterate through the results. When you call the same query again, the next document will be automatically become the new current payload.

I’m using Tamino 4.1.4

The query step is only for testing the database access. It returns all the “Traza” documents, but it is only a test. What I really want to do is the insertion of a new document.

What the “connections container” could be?

Are you having this problem when running the debugger? A friend reminded me of a bug we had in this version when testing sequences which had Tamino connections.

If this is the case, try testing the sequence using a test document. This avoids the constant communication between the studio and runtime.

The problem is corrected in the current version - 7.4.2.

Dear Matthew…

:lol: :lol: :lol: :lol: :lol: :lol: :lol:

IT WORKS :!: :!: :!:

:lol: :lol: :lol: :lol: :lol: :lol: :lol:

It’s a debugger problem, as you said.

Thanks 4 all.