Problem in fireCommandExec

I am running fireCommandExec service passing a batch file parameter to fullCommand in ServiceIn. The batch file has some CVS commands to run. The problem is that when it executes fireCommandExec service, it just hangs on it and doesn’t go to next step in flow. I found that when CVS command is triggered in a batch file, the service hangs there and seems waiting for some return code. Interesting thing is that cvs command successfully completes the work.

Running batch file from command prompt is ok.

Does anybody faced the same problem.


There might be 2 issues with this.

  1. If you exec the command from the prompt, are you using the same user as with which IS is started? If so, run a “set” command (both Unix & Windows) and have it return the environment vars for both exec methods. Match these & see if the issue is found there.
  2. When exec-ing an external command in Java (which is probably the core of the fireCommandExec) a very large part of the JVM is duplicated to perform this exec. If your IS is using 2G mem (as does ours), you will need at least another 1G to spare to be able to call an external command.

Good luck, Chris

Hi Chris,
Thanks for the comments. The problem is solved. Actually, processes were running concurrently so the first process locks the file while the following process fails or trying to execute. I tried inserting “start /w” before each command in batch file to make CMD wait the process termination before interpreting next command line and it ran successfully without hanging.