Postgre odata

Detailed explanation of the problem:

Hi, i’m trying to create an OData services attached to a postgreSQL.

I configured my connection like this and the connection is enabled :

I created my odataServices successfully :

But an error ocurred :

It looks like the request isn’t well formed postgre need double quotes like this :
select hi.“ID_INTERACTION” from “SCH_HIST_INT”.“HIST_INTERACTIONS” hi order by 1 offset 0 fetch next 10 rows only
rather than :
select ID_INTERACTION from SCH_HIST_INT.HIST_INTERACTIONS hi order by 1 offset 0 fetch next 10 rows only

I found this information
webMethods Adapter for JDBC Documentation (

And try the parameter at true and false with no change.

Do you have any idea what i am missing?

Product/components used and version/fix level:

IS 10.11
Driver : postgresql-42.7.1.jar

Is there any fix applied to your JDBC driver and/or IS? These kind of bugs are usually fixed after installing the latest fixes unless the version very recent. I recommend installing the latest fixes and check if it solves your issue.

Any reason to use such an ancient version of PostgreSQL? It has been EOL for a few years now with v12 being the oldest that is still supported.

Thank you for your answers.

I tried with new database with postgre V16
I tried with an IS updated with recent fixe.

But i still have the same behaviour.

The connection in the jdbc adapter seems to ignore the attribute, that should enclose with quote the element of the request.

I may be totally wrong here. But doesn’t the mixed upper/lower-case nature of the error indicate that case sensitivity should actually be turned off?

Edit: Besides it is my understanding that PostgreSQL is by default case-sensitive.