"port already in use" when installing MWS in Vista

I tried to install MWS in Vista, but keep getting error “Port number is already in use”. I tried different port number such as 8585, 8989, and anything, but still get the same error. It only happened to my Vista machine.
Any idea how to resolve this?

seriously dude, dont use vista for webmethods, atleast run vmware and run xp inside of it for webm development

I was able to run 7.0 in Vista. But with 7.1, it is giving me the “port number already in use” error.

that is true but my greater point is that vista is a really bad place to run the webmethods software natively I think. Maybe you can run your developer/ designer there but IS and Broker isnt a good idea in my opinion.

Install vmware and run a windows XP image, you will have a much smoother time

hi,
i installed the whole wM stuff including IS, broker, mws, TN on vista and it works fine. but i used more-less clean clean vista only with oracle 10g db. of ocurse vista has some issues with performance and memory usage, but definitely your problem is not connected to the OS vista.

jan

What version do you have on Vista? Is it 7.1? I was able to install 7.0 but not 7.1.

Hi,

I am facing the same problem here while installing 7.1.1
However the OS is RED HAT LINUX AS 4.0,

Did anyone got to know what is the problem.

Regards,
Sumit

Hi Sumit

Are you able to resolve the above port problem.
We are currently facing the same. CAn you please share the info if you are able to cross this hurdle.

Regards
Vijay

Hi

I’m have the same error while use the webMethodsInstaller 7.1 when try install the MWS 7.1.2.

The error is:
The port number 8585 is already in use. Please enter a diferent port number.
The error is on Solaris 10

I’m trying diferent port and not happened nothing.

Does someone have a solution?

Regards
IRuiz

Hi
I could solve the problem only shutting down the server Solaris and try the installation again.

If anyone has other solutions, pleasse discuss here.

The solution is configuring /ect/hosts file with: hostname ipaddress.

I will not discuss about windows issue because I’m not (and don’t want be) familiar with this brain damaged and time consuming ^$7@#&^#*#

Anyway, on Unix, you have a tool named lsof that allows you to know which process own a port : e.g.

lsof tcp:8585

On some OS (as Solaris as far I remember) you need to be root to got accurate responses (otherwise, lsof sticks on your own processes).

Alternatively, you can use also netstat.

Another best practices is to add the needed port in /etc/services in order to avoid another process to accidentally own it.

Hoping it helps.