Point Two non-clustered IS to one TN DB

Hello Guys,

I have a need to point two non-clustered Integration Servers to the same TN DB. From this thread here I concluded that it is safe to do so. But I have a situation here. One of the two Integration Servers is a B2B node which is already connected to the TN DB. So it has all the components needed to be able to a B2B node. The other is only an A2A node and needed to be converted to B2B node to be able to use TN.

Is there a checklist or cheatsheet to make it the clean way? I have filed the differences from the IS About page and the package updates page. Is it clean way to copy the the missing packages and other artifacts from the B2B node to the A2A node? Any other ideas?

Thanks
Guna

I don’t have the specific steps for connecting an existing IS instance to another existing IS/TN instance but I do have this advice–do NOT copy wM-supplied packages from one instance to the other. Use the SAG installer.

What packages are you saying missing on A2A? webMethods provided or custom packages?

Yes as Rob said don’t copy TN/dependent packages better do install it and yes you can point IS’s to the same TN db (non clustered ISes):

HTH,
RMG

Hi Rob & RMG,

The missing packages are Wm provided ones and the related jar files. Are you suggesting to download the image that includes these packages and then install them onto the A2A node using Installer?

Cheers
Guna

Yes, use the installer. Do not copy them.

Rob,

I have downloaded the image and istalled it locally for verification. It contains all other packages such as WmART, WmRoot etc which are already upto date on the A2A node. Is there any other way to only install the missing TN, EDI components?

Guna

If your image file doesn’t list TN and EDI components, you have to create a newer image from empower site, and make use of that to install TN and EDI component.

-Senthil

Yes please follow as Senthil mentioned above…May be the image is not updated with TN/EDI Adapter components…

Did you check it with your team/admin?

HTH,
RG

Ok here is what I did to make it work step-by-step, in case someone needs it in future

  1. Took the server offline backup
  2. Installed the TN, EDI modules and SAP Adapter through Installer
  3. Installer had overwritten JVM to a lower version than what we already had (difference in build number), so restored the JVM from backup.
  4. Installed latest TN fix on both the servers. In WmTN/config/properties.cnf added the remote aliases for the other node - “tn.cluster.sync.remoteAliases”, tn.cluster.notifyProfileAddUser=true, tn.cluster.notifyCacheChange=true (needed as per the document even though they are not clustered)
  5. Restarted the server. Logging through TN console worked but couldn’t query profiles and transactions. Modified the tangsol-coherence-override.xml for unicasting and then did this goofy thing - In IS cluster settings - enabled clustering --> restarted the server --> again disabled clustering --> restarted the server
  6. In IS admin proxy settings, bypassed the proxy for the other node using the same TN db (both the servers are on the local domain)
  7. Created the remote alias as mentioned in the TN properties.cnf file, tested for connectivity.
  8. Reloaded the WmTN package
  9. Repeated steps -4, 6, 7 and 8 for the other node.
  10. Synchronization is working fine for common objects (profiles, doc types, attributes etc). Both the nodes are working seamlessly.
  11. Has to accept that the enterprise profile can only accommodate one set of key pairs only and if need be a second partner profile would be created which then be treated as enterprise profile for this new B2B node.

Cheers
Guna

very elaborate and it make sense:

One note that may be of interest for others–in the various TN projects I’ve done we never used the enterprise profile for any deliveries. Too limiting. We used it to hold some configuration info for error handling but that was it. For all document exchanges partner profiles were used, including for internal apps.

It’s been true in our case also…:slight_smile:

Rob thanks for the tip, I would definitely add this to the best practices list.