Permission issue when importing packages


I have web service for which i have given execute ACL as ‘Anonymous’. I created the archive (.zip) from IS admin and copied this archive to other machine under /replicate/inbound folder and then imported this archive.
However, when i try to access the service it gives access denied. And when i checked the permission for web service descriptor on new machine it was ‘Default’ and not ‘Anonymous’.
is that correct behaviour? How can i ensure that permissions remain intact?


even I faced similar issue some time back but in my case source IS version is 8.2 and target version is 9.5.

Not sure in your case, it is better to have this check in the post-deployment steps.


Even I have the same observation, I hope this is default behaviour when you copy from one to other environment.



this is definitely default behaviour.

The information about the ACLs is not stored with the service but resides in specific config files under IntegrationServer/config.

An Option will be to use Deployer for such deployments as this will also transport the ACL-assignments.
But Deployer is not able to deploy across different versions (i.e. 8.2 to 9.5).

In this case the ACL-assignments have to be done manually on each target after the deployment.