Partner Specific EDITPA

Hello everyone :slight_smile: ,
I’m working on WM’s EDI module. We’ve a requirement which needs Partner specific EDITPA to be defined. I’ve gone through the documentations and wrote a TPA in which I gave splitOption=Group.
Now, when I push an EDI message through “EDI Module home page”/“flowService”, I see entries in TN showing the splitting of EDI message at transaction level.
After debugging a lot I came to a conclusion that the default EDITPA is getting hit every time I push an EDI message. So, tried a few permutations/combinations:

  1. Modified the default EDITPA and set splitOption to “Group” which worked.
  2. Deleted the default EDITPA and pushed an EDI message, which resulted in some erroneous state and I didn’t get any entry in TN. However, my partner specific TPA was still there.

So, I can easily reason out that partner specific TPA is not getting hit. Could anyone please, suggest me why this is happening.
Any kind of help is highly appreciated.

Your partner-specific TPA must be called EDITPA and not ‘Copy of EDITPA’ or whatever it defaults to when you create it. Also, the TPA should correspond to the transaction flow. That is, for documents from the partner to you, the TPA should have the partner as the sender and you as the receiver. If all this is correct, you should have no problem picking up the right TPA. HTH,


To add to what Tim has written the IDs in the EDI file should be present in the TN profile so that the Trading Partners are identified in TN and subsequently the TPA.

Thanks for the quick response.:slight_smile:

The name I had given against AgreementID was EDIX125010. Did that make any difference?

In EDIModuleUsersGuilde I’ve read that one need to define some setting on EDI Module home page under the following header ‘Partner Setup->Manage Interchange Info’ in order to process documents splitted at transaction & group level. So, I’ve a few questions regarding that:-
1. In what way that setting is different from one we define in TN Console?:confused:
2. Can we do away with default EDITPA by providing those settings/information?

What role does Control number plays in EDI processing?
Do we need to specify control number while defining Partner Specific EDITPA? If yes, then why? If no, then also why?

The Agreement ID must be EDITPA. See the EDI Module User’s Guide, which has a section on partner-specific EDITPAs.



Why is the AgreementID was EDIX125010?? while it should be EDITPA…Any custom requirement for using diff ID??


I didn’t know that it can’t be other than EDITPA. So, I just gave one that matches EDI transaction & version.

Anyways, I’ve corrected it and it’s working fine now.

Thank you everyone for helping me out.:smiley:

:slight_smile: Glad to hear it is working now…Well thats why these forums are here to help our issues…:slight_smile: