Packages locking and unlocking

Hello Experts,

Iam facing problem with my packages in Designer that are not locking and unlocking. Iam using webMethods 9.8V.
Previously it used to work…Now Iam not getting …Help me to solve this.

Do you see any error while trying to lock / unlock?
It must be permission issue preventing you to do the operation.
Have you tried with administrator?

Whenever I used to lock the package .Its not getting highlighted…


Not getting highlighted? Are you able to click on unlock or the selection itself is not happening?

Is it possible to share a screen shot of the issue you are facing.

Please share the version and fix level for the environment you are facing the issue with.

Hello Khan,
I have attached the screen shot and the version is webMethods9.8 ,its a trail version

check the value of the watt parameter “watt.server.ns.lockingMode” .
The Integration Server to which you are connected may have the watt.server.ns.lockingMode property configured to “none” or “system.”

Ask your webMethods Administrator to change the value of “watt.server.ns.lockingMode” to full

If you are using Local Service Development feature , then On the Integration Server used as the local development server, the
watt.server.ns.lockingMode parameter must be set to system.

1 Like


I am using local integration server , and I could see this property set to the “system” in the path
E:\SoftwareAG98\IntegrationServer\instances\default\config -server.conf file.

I believe then , you have installed Local Service Development feature as well. Then it is the expected behavior.
You should be able to edit the services.

You can see the attachment that those options are not getting highlighted…so that Im not able to edit the Services

For more information and clarity, refer my comments at the below link:

It got solved…Thankyou